
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head id="ctl00_Head1">
<script type='text/javascript'>        var_sf_startpt = (new Date()).getTime()</script>
<meta name="robots" content="noarchive" /><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible" /><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info = {"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"7f3747c05c","applicationID":"2084172","transactionName":"YlBWN0ZWWEAAUkEKXlsadTBkGF9BBF1UDVUaUVEFVUJaR09QRhNJ","queueTime":0,"applicationTime":9,"ttGuid":"DA560E293CB7F097","agent":""}</script><script type="text/javascript">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</script><meta name="viewport" content="initial-scale=1,maximum-scale=1,user-scalable=no" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Top Stories" href="//feeds.examiner.ie/ietopstories" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Ireland" href="//feeds.examiner.ie/ieireland" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Sport" href="//feeds.examiner.ie/iesport" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: World" href="//feeds.examiner.ie/ieworld" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Business" href="//feeds.examiner.ie/iebusiness" />
<meta property="fb:app_id" content="1567359720193705" /><meta property="fb:pages" content="175322202485450" />
<title>
        Concern over quality of Irish teaching in schools | Irish Examiner</title>
<link href="/assets/css/app.min.css" media="screen" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="/assets/js/lbp.min.js"></script>
<script type="text/javascript" src="/assets/js/head.min.js"></script>
<script type="text/javascript">
        head.js({ jquery: '//ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js' }, { modernizr: '/assets/js/modernizr.min.js' }, { all: '/assets/js/all.js' }, { homescreen: '/assets/js/addtohomescreen.min.js' }, { login: '/js/login.js' }, { updatePage: '/js/updateDetails.js' }, { stickyads: '/assets/js/stickyads.min.js' });
    </script>

<script type="text/javascript" src="https://native.sharethrough.com/assets/sfp.js"></script>

<script type="text/javascript" src="https://cdns.gigya.com/js/gigya.js?apiKey=3_VvF1UthGmxN4wtFIlgliEKHP3VTywNTuqe1saB-DqNTlwgUjZ4zejDQ1beegQt-J">
    {
	    siteName: 'irishexaminer.com (Irish Examiner)',
        enabledProviders: 'facebook,twitter,googleplus,linkedin'
    }
    </script>
<script type="text/javascript">
            head.js({ galleria: '/assets/galleria/galleria-1.4.2.min.js' }, { bbw: '//landmark.bbvms.com/launchpad/' }, { bbwplay: '/assets/bbw/player.min.js' });
        </script>



<meta name="description" content="Headline Concern over quality of Irish teaching in schools" />
<link rel="image_src" href="https://www.irishexaminer.com/remote/media.central.ie/media/images/p/PrimarySchoolChildrenGeneric_large.jpg?width=648&s=ie-466736" />
<meta prefix='og: http://ogp.me/ns#' property="og:type" content="article" />
<meta prefix='og: http://ogp.me/ns#' property="og:url" content="http://www.irishexaminer.com/ireland/concern-over-quality-of-irish-teaching-in-schools-466736.html">
<meta prefix='og: http://ogp.me/ns#' property="og:image" content="http://www.irishexaminer.com/remote/media.central.ie/media/images/p/PrimarySchoolChildrenGeneric_large.jpg?width=648&s=ie-466736" />
<meta prefix='og: http://ogp.me/ns#' property="og:image:width" content="600" />
<meta prefix='og: http://ogp.me/ns#' property="og:image:height" content="325" />
<meta prefix='og: http://ogp.me/ns#' property="og:title" content="Concern over quality of Irish teaching in schools" />
<meta prefix='og: http://ogp.me/ns#' property="og:description" content="There has been a marked deterioration in the standard of Irish among pupils in primary schools." />
<meta property="article:published_time" content="2018-02-06T00:00:00+00" />
<meta property="article:publisher" content="https://www.facebook.com/irishexaminer" />
<meta property="article:tag" content="Ireland" />
<meta property="article:section" content="Ireland" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@irishexaminer">
<meta name="twitter:title" content="Concern over quality of Irish teaching in schools" />
<meta name="twitter:url" content="http://www.irishexaminer.com/ireland/concern-over-quality-of-irish-teaching-in-schools-466736.html">
<meta name="twitter:description" content="There has been a marked deterioration in the standard of Irish among pupils in primary schools." />
<meta name="twitter:image" content="http://www.irishexaminer.com/remote/media.central.ie/media/images/p/PrimarySchoolChildrenGeneric_large.jpg?width=648&s=ie-466736" />
<link rel="canonical" href="https://www.irishexaminer.com/ireland/concern-over-quality-of-irish-teaching-in-schools-466736.html" />
<link rel="amphtml" href="https://amp.irishexaminer.com/ireland/concern-over-quality-of-irish-teaching-in-schools-466736.html" />
<meta name="news_keywords" content="Education, Ireland" />
<script type="text/javascript">
dataLayer = [{"pageType":"Article","pageTitle":"Concern over quality of Irish teaching in schools","pageCategory1":"Ireland","pageCategory2":"","pageCategory3":"","pageAttributes":{"comments":"on","images":"1","youtube":"0","twitter":"0","facebook":"0","soundcloud":"0","doccloud":"0"},"pageArticleID":"466736","pageAuthorID":"Conall Ó Fátharta","pageSource":"ie_iestaff","pageAuthorName":"Conall Ó Fátharta","pageKeywords":["Education"]}];
</script>
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];

            var advelvetTargeting = [];
                advelvetTargeting.push((Math.floor(Math.random() * 20) + 1) + "");
                googletag.cmd.push(function () {
                    googletag.pubads().setTargeting('advelvet', advelvetTargeting);
            });

            (function () {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
            })();
        </script>

<script type='text/javascript'>
googletag.cmd.push(function() {
n_ie_leader_728x90 = googletag.defineSlot('/1005055/n_ie_leader_728x90', [[728, 90],[970, 250],[970, 90]], 'div-gpt-ad-1346688247801-0').addService(googletag.pubads());
n_ie_banner_650x90 = googletag.defineSlot('/1005055/n_ie_banner_650x90', [650, 90], 'div-gpt-ad-1468573711486-0').addService(googletag.pubads());
n_ie_placeholder_1x1 = googletag.defineSlot('/1005055/n_ie_placeholder_1x1', [1, 1], 'div-gpt-ad-1346688247801-12').addService(googletag.pubads());
n_ie_placeholder_2x2 = googletag.defineSlot('/1005055/n_ie_placeholder_2x2', [1, 1], 'div-gpt-ad-1346688247801-3').addService(googletag.pubads());
n_ie_marketing_298x73 = googletag.defineSlot('/1005055/n_ie_marketing_298x73', [298, 73], 'div-gpt-ad-1346688247801-4').addService(googletag.pubads());
n_ie_marketing_mpu = googletag.defineSlot('/1005055/n_ie_marketing_mpu', [300, 250], 'div-gpt-ad-1479983964240-0').addService(googletag.pubads());
n_ie_mpu_end_300x250 = googletag.defineSlot('/1005055/n_ie_mpu_end_300x250', [[300, 250],[300, 600]], 'div-gpt-ad-1346688247801-1').addService(googletag.pubads());
n_ie_mpu_start_300x250 = googletag.defineSlot('/1005055/n_ie_mpu_start_300x250', [[300, 250],[300, 600]], 'div-gpt-ad-1346688247801-2').addService(googletag.pubads());
n_ie_sharethrough_instory_2x1 = googletag.defineSlot('/1005055/n_ie_sharethrough_instory_2x1', [2, 1], 'div-gpt-ad-1495459500257-0').addService(googletag.pubads()).setTargeting('strnativekey','rgLt2mjz7xQaDGWA7xxhVwjK');
n_ie_sharethrough_2x1_1 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-1').addService(googletag.pubads());
n_ie_sharethrough_2x1_2 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-2').addService(googletag.pubads());
n_ie_sharethrough_2x1_3 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-3').addService(googletag.pubads());
n_ie_sharethrough_2x1_4 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-4').addService(googletag.pubads());
n_ie_sharethrough_2x1_5 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-5').addService(googletag.pubads());
googletag.pubads().setTargeting('strnativekey','CwbKs52hkbo573Q9KzUoxJEt');
googletag.pubads().setTargeting('n_section', 'ie_ireland');
googletag.pubads().setTargeting('n_channel', 'storypage');
googletag.pubads().setTargeting('n_passback', 'false');

    googletag.pubads().setTargeting('n_story_id', 'ie_466736');
googletag.pubads().setTargeting('n_keywords', ['inskin_yes','Education']);
    var fn_pageskin = 'false'; if (screen.width >= 375) { fn_pageskin = 'true'; }
    googletag.pubads().setTargeting('inskin', fn_pageskin);
googletag.pubads().setTargeting('n_group', '3543');
googletag.pubads().setTargeting('n_source', 'ie_iestaff');
googletag.pubads().setTargeting('n_author', 'Conall Ó Fátharta');

googletag.pubads().disableInitialLoad();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

document.onreadystatechange = function(){
  function lazyloadAd(adUnit, adID){
    var adSlot = document.getElementById(adID);
    if (typeof(adSlot) != 'undefined' && adSlot != null){
      var adSlotRect = adSlot.getBoundingClientRect();
      var adSlotPosition = adSlotRect.top;
      var adSlotRefreshed = false;
      var adAlmostVisibleScrollValue = adSlotPosition - window.innerHeight - 500;
      var listener = function() {
        if (adAlmostVisibleScrollValue <= window.scrollY && !adSlotRefreshed){
          googletag.cmd.push(function() {
            googletag.pubads().refresh([adUnit]);
            console.log('Ad displayed!');
          });
          adSlotRefreshed = true;
          window.removeEventListener('scroll', listener);
        }
      }
      window.addEventListener('scroll', listener);
    }
  }
}
});
</script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'https://cdn.taboola.com/libtrc/landmarkdigital-irishexaminer/loader.js',
  'tb_loader_script');
</script>
<script type="text/javascript">
            var _sf_async_config = _sf_async_config || {};
            _sf_async_config.uid = 39796;
            _sf_async_config.domain = 'irishexaminer.com';
            _sf_async_config.useCanonical = true;
            var _sf_startpt = (new Date()).getTime();
        </script>
<script src="https://static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript"> function isLoggedIn(s) { if (0 == s.errorCode) { var a = parseInt(s.data.irelandtoday); a ? a += 1 : a = 1; var t = s.data.irelandtoday_firstread; a ? a += 1 : a = 1; var n = (new Date).toISOString(); if (t) var r = { data: { irelandtoday: a.toString(), irelandtoday_lastread: n.toString() } }; else var r = { data: { irelandtoday: a.toString(), irelandtoday_lastread: n.toString(), irelandtoday_firstread: n.toString() } }; gigya.accounts.setAccountInfo(r) } } var logParams = { callback: isLoggedIn }; gigya.accounts.getAccountInfo(logParams); </script>

<title>

</title></head>
<body class="cbp-spmenu-push basic-template">




<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TJMCD4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>    (function (w, d, s, l, i) {
        w[l] = w[l] || []; w[l].push({ 'gtm.start':
new Date().getTime(), event: 'gtm.js'
        }); var f = d.getElementsByTagName(s)[0],
j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : ''; j.async = true; j.src =
'//www.googletagmanager.com/gtm.js?id=' + i + dl; f.parentNode.insertBefore(j, f);
    })(window, document, 'script', 'dataLayer', 'GTM-TJMCD4');</script>

<div class="mob-overlay">
</div>
<div class="top-bar">
<div class="container">
<ul class="left">
<li><a href="/epaper/">ePaper</a></li>
<li><a href="/info/postaldeliveryenquiry/">Postal Delivery</a> </li>
<li><a href="http://photos.examiner.ie/" target="_blank">Photos</a> </li>
<li><a href="/competitions/">Competitions</a> </li>
<li><a href="/archive/">Newspaper Archive</a> </li>
<li><a href="http://ads.irishexaminer.com/">Advertise With Us</a> </li>
<li class="active"><a href="/shop/">Shop</a> </li>
<li><a href="/deathnotices/">Death Notices</a> </li>
</ul>
<ul class="right">
<li>Find a... </li>
<li><a href="/property/"><span class="icon-home"></span>Home</a> </li>
<li><a href="http://www.recruitireland.com" target="_blank"><span class="icon-case">
</span>Job</a> </li>
</ul>
</div>
</div>
<header>
<div class="container">
<a class="logo" href="/">IrishExaminer</a><button id="showLeftPush"><span class="icon-menu"></span></button>
<div class="banners"><div id='Marketing_Top' data-cb-ad-id='Marketing_Top' class='ad'><div id='div-gpt-ad-1346688247801-4' style='width:298px; height:73px;'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-4');googletag.pubads().refresh([n_ie_marketing_298x73 ]);});</script></div></div></div>
</div>
</header>
<div class="container">
<nav class="cbp-spmenu cbp-spmenu-vertical cbp-spmenu-left" id="cbp-spmenu-s1">
<span class="header">Menu
<button id="hideLeftPush">
<span class="icon-close"></span>
</button>
</span>
<ul>

<li class="main-menu"><span id="loginTextMobile"><a onclick="toDo()" class="loginClassMobile">Login</a></span></li>
<li class="main-menu"><span id="logoutButtonMobile"></span></li>
<li class="active main-menu"><a href="/">Home mobile</a> </li>
<li class="main-menu"><a href="/maintopics/">Hot Topics</a> </li>
<li class="current main-menu">
<span class="news"><a href="/ireland/">News</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/breakingnews/">- Breaking News</a></li>
<li><a href="/ireland/">- Today's Stories</a></li>
<li><a href="/specialreports/">- Special Reports</a></li>
<li><a href="/breakingnews/world/">- World</a></li>
<li><a href="/breakingnews/farming/">- Farming</a></li>
<li><a href="/weather/">- Weather</a></li>
<li><a href="/archives/">- Web Archive</a></li>
<li><a href="/archive/">- Newspaper Archive</a> </li>
</ul>
</li>
<li class="current main-menu1">
<span class="news"><a href="/sport/">Sport</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/breakingnews/sport/">- Breaking News</a></li>
<li><a href="/sport/gaa/">- GAA</a></li>
<li><a href="/sport/gaa/football/">- Football</a></li>
<li><a href="/sport/gaa/hurling/">- Hurling</a></li>

<li><a href="/sport/rugby/">- Rugby</a></li>
<li><a href="/sport/soccer/">- Soccer</a></li>
<li><a href="/sport/racing/">- Racing</a></li>
<li><a href="/sport/golf/">- Golf</a></li>
<li><a href="/sport/other-sports/">- Others</a></li>
<li><a href="/sport/columnists/">- Columns</a></li>
</ul>
</li>
<li class="current main-menu2">
<span class="news"><a href="/breakingnews/lifestyle/">Lifestyle</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/breakingnews/lifestyle/artsfilmtv/">- Culture</a></li>
<li><a href="/breakingnews/lifestyle/fashionandbeauty/">- Fashion/Beauty</a></li>
<li><a href="/breakingnews/lifestyle/features/">- Features</a></li>
<li><a href="/breakingnews/lifestyle/foodanddrink/">- Food/Drink</a></li>
<li><a href="/breakingnews/lifestyle/healthandlife/">- Health/Life</a></li>
<li><a href="/breakingnews/lifestyle/outdoors/">- Outdoors/Garden</a></li>
<li><a href="/breakingnews/entertainment/">- Showbiz</a> </li>
<li><a href="/breakingnews/lifestyle/travel/">- Travel</a></li>
<li><a href="/breakingnews/lifestyle/homeandinteriors/">- Home</a></li>
</ul>
</li>
<li class="current main-menu3">
<span class="news"><a href="/breakingnews/views/">Viewpoints</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/viewpoints/columnists/">- Columns</a></li>
<li><a href="/breakingnews/views/analysis/">- Analysis</a></li>
<li><a href="/breakingnews/views/ourview/">- Our View</a></li>
<li><a href="/breakingnews/views/yourview/">- Your View</a></li>
<li><a href="/viewpoints/letters/sendletter">- Send your views</a></li>
</ul>
</li>
<li class="current main-menu4">
<span class="news"><a href="/video/">Video</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/video/news/">- Video News</a></li>
<li><a href="/video/sport/">- Video Sport</a></li>
<li><a href="/video/lifestyle/">- Video Lifestyle</a></li>
<li><a href="/video/viral/">- Video Viral</a></li>
<li><a href="/video/youmayhavemissed/">- Video You May Have Missed</a></li>
</ul>
</li>
<li class="current main-menu5">
<span class="news"><a href="/breakingnews/business/">Business</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/breakingnews/technow/">- Technology</a></li>
</ul>
</li>
<li class="current main-menu6">
<span class="news"><a href="/examviral/">ExamViral</a></span>

</li>
<li class="main-menu"><a href="/breakingnews/technow/">Technow</a></li>
<li class="current main-menu8">
<span class="news"><a href="/property/">Property</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="http://property.examiner.ie">- Property Search</a></li>
</ul>
</li>
<li class="main-menu"><a href="/breakingnews/entertainment/">Showbiz</a></li>
<li class="main-menu"><a href="/lifestyle/horoscopes/">Horoscopes</a></li>
<li class="main-menu"><a href="/deathnotices/">Death Notices</a></li>
<li class="current main-menu10">
<span class="news"><a href="/info/help/">Help</a><span class="arv"></span></span>
<ul class="submenu">
<li class="main-menu"><a href="/info/advertisingenquiry/">- Advertise With Us</a> </li>
<li class="main-menu"><a href="/getmobile/">- Apps</a></li>
<li class="main-menu"><a href="/competitions/">- Competitions</a> </li>
<li class="main-menu"><a href="/epaper/">- ePaper</a></li>
<li class="main-menu"><a href="http://photos.examiner.ie/" target="_blank">- Photos</a> </li>
<li class="main-menu"><a href="/info/postaldeliveryenquiry/">- Postal Delivery</a> </li>
<li class="main-menu"><a href="/shop/">- Shop</a> </li>
</ul>
</li>
<li class="current main-menu11">
<span class="news"><a href="#">Find a</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="http://property.examiner.ie/" target="_blank">- Home</a> </li>
<li><a href="https://www.recruitireland.com/" target="_blank">- Job</a> </li>
</ul>
</li>
<li class="current main-menu12">
<span class="news"><a href="#"></a></span>
<ul class="submenu"></ul>
</li>
<li class="current main-menu13">
<span class="news"><a href="#"></a></span>
<ul class="submenu"></ul>
</li>
</ul>
</nav>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
<script type="text/javascript">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</script>
<nav class="main">
<div class="container">
<ul>
<li><a href="/">News</a></li>
<li><a href="/sport/">Sport</a></li>
<li><a href="/breakingnews/business/">Business</a></li>
<li><a href="/breakingnews/views/">Views</a></li>
<li><a href="/breakingnews/lifestyle/">Life</a></li>
<li><a href="/breakingnews/examviral/">ExamViral</a></li>
<li><a href="/property/">Property</a></li>
<li><a href="/breakingnews/technow/">Tech</a></li>
<li><a href="/video/">Video</a></li>
<li><a href="/breakingnews/entertainment/">Showbiz</a></li>
<li><a href="/motors/">Motoring</a></li>
</ul>

<ul class="loginNav">
<li id="loginMenu"><span id="userLoginIcon"><img alt="" id="login-user-icon" src="/images/social/icon-user-you.png" /></span><span id="loginText"><a onclick="toDo()" class="loginClass">Login</a></span></li>
<li><span id="logoutButton"></span></li>
</ul>
<div class="search">
<form action="//www.irishexaminer.com/search/">
<input type="hidden" name="cx" value="004422957488353982429:4gb73lvknqy" />
<input type="hidden" name="cof" value="FORID:9" />
<input type="hidden" name="ie" value="UTF-8" />
<input type="text" name="q" placeholder="SEARCH SITE" /><button type="submit">go</button>
</form>
</div>
</div>
</nav>

<nav class="secondary">
<div class="container">
<ul id="secondary-nav">
<li class="selected">
<a href="/breakingnews/">Latest</a><span class="icon-subnav dropdown-trigger"></span>
<ul>
<li><a href="/breakingnews/ireland/">Ireland</a></li>
<li><a href="/breakingnews/world/">World</a></li>
<li><a href="/breakingnews/sport/">Sport</a></li>
<li><a href="/breakingnews/business/">Business</a></li>
<li><a href="/breakingnews/entertainment/">Showbiz</a></li>
<li><a href="/breakingnews/lotto/">Lotto</a></li>
</ul>
</li>
<li><a href="/ireland/">Ireland Today</a></li>
<li><a href="/breakingnews/business/">Business</a></li>
<li><a href="/breakingnews/farming/">Farming</a></li>
<li><a href="/breakingnews/world/">World</a></li>
<li><a href="/deathnotices/">Deaths</a></li>
<li>
<a href="/weather/">Weather</a><span class="icon-subnav dropdown-trigger"></span>
<ul>
<li><a href="/weather/">National Weather</a></li>
<li><a href="/weather/connacht/">Connacht</a></li>
<li><a href="/weather/leinster/">Leinster</a></li>
<li><a href="/weather/munster/">Munster</a></li>
<li><a href="/weather/ulster/">Ulster</a></li>
<li><a href="/weather/world/">World</a></li>
</ul>
</li>
<li>
<a href="#">More</a><span class="icon-subnav dropdown-trigger"></span>
<ul>
<li><a href="/archives/">Web Archive</a></li>
<li><a href="/horoscopes/" target="_blank">Horoscopes</a></li>
<li><a href="/specialreports/">Special Reports</a></li>
</ul>
</li>
</ul>
<ul id='secondary-nav'><li class='hottopics'><a href='/maintopics/'>HOT TOPICS:</a></li><li><a class='groupinnav' href='/maintopics/kerry-babies-4561.html'>Kerry Babies</a></li><li><a class='groupinnav' href='/maintopics/charleton-tribunal-4477.html'>Charleton Tribunal</a></li><li><a class='groupinnav' href='/maintopics/8th-amendment-4379.html'>8th Amendment</a></li></ul>
</div></nav>




</div>
<div id="leaderboard" class="container">
<div class="leaderboard flash-950">
<div id='LeaderTop' data-cb-ad-id='Leader' class='ad'><div id='div-gpt-ad-1346688247801-0'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-0');googletag.pubads().refresh([n_ie_leader_728x90]);});</script></div></div>
</div>
</div>

<div class="breadcrumbs">
<div class="container">
<a href="/">Home</a><span>&raquo;</span><a href='/ireland/'>Today's Stories</a>
</div>
</div>

<div class="container content">
<div class="col-wrapper">
<div class="col-left-story">
<h1>Concern over quality of Irish teaching in schools</h1><div class='share-buttons clearfix'>
<div id='shareDiv'>
</div>
<script type="text/javascript">
function chkButton(btn) {
if (btn.shareItem.provider == 'comments') {
var comDiv = document.getElementById('commentsDiv');
comDiv.scrollIntoView(false); } }
var act = new gigya.socialize.UserAction();
act.setLinkBack("http://www.irishexaminer.com/ireland/concern-over-quality-of-irish-teaching-in-schools-466736.html");
act.setTitle("Concern over quality of Irish teaching in schools");
var showShareBarUI_params_side = {
 containerID: 'shareDiv',
shareButtons: [
{provider: 'facebook', tooltip: 'Recommend this on Facebook', iconImgUp:'/images/social/facebook-gigya.png', iconOnly: true},
{provider: 'twitter', tooltip: 'Share on Twitter', iconImgUp:'/images/social/twitter-gigya.png', iconOnly: true},
{provider: 'googleplus', tooltip: 'Share on Google+',  iconImgUp:'/images/social/googleplus-gigya.png', iconOnly: true},
{provider: 'share', tooltip: 'More share options',  iconImgUp:'/images/social/more-gigya.png', iconOnly: true, enableCount:false} 
],
 onShareButtonClicked: chkButton, 
 userAction: act };
</script>
<script type="text/javascript">gigya.socialize.showShareBarUI(showShareBarUI_params_side);</script>
</div><div class="byline">Tuesday, February 06, 2018</div><div class='byline'><div class='author clearfix'><span class='face'><img src='https://media.central.ie/media/house/ieauthors/conallofatharta.jpg'></span><span class='name'><a>By Conall &Oacute; F&aacute;tharta</a><br>Irish Examiner Reporter</span><ul class="share-links"><li><a href="https://twitter.com/ococonuts" class="twitter-follow-button" data-show-count="false">Follow @ococonuts</a>
<script> !function(d,s,id){ var js,fjs=d.getElementsByTagName(s)[0]; if(!d.getElementById(id)) {js=d.createElement(s); js.id=id; js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js,fjs); } }( document,"script","twitter-wjs"); </script></li></ul></div></div><div class='generic-text'>
<div class="ctx_content"><p><p>There has been a marked deterioration in the standard of Irish among pupils in primary schools.</p></p><div class='story-image'><img itemprop="image" src="/remote/media.central.ie/media/images/p/PrimarySchoolChildrenGeneric_large.jpg?width=648&s=ie-466736" width="648" class=" addthis_shareable" /></div><story><p><p>A new report raises concern over the quality of teaching of Irish at primary and secondary level.</p>
<p>It is one of a number of issues raised in the latest report by the Chief Inspector of the Inspectorate of the Department of Education and Skills, Harold Hislop.</p>
<p>Based on almost 5,000 school inspections conducted between 2013 and 2016, the report found that a &ldquo;significant cohort&rdquo; of children are not making appropriate progress in Irish and that standards in the language are poorer than those in English and maths.
<p>In primary schools, the quality of teaching and learning of Irish was deemed &ldquo;less than satisfactory&rdquo; in 28% of schools examined, compared to just 4% for maths classes and 7% for English classes.</p>
<p>The quality of teaching and learning of Irish was found to be very good in just 12% of the primary schools inspected, compared to 33% for maths classes and 27% for English classes.</p>
<p>The report notes that &ldquo;challenges persist&rdquo; at post-primary level but that there had been an improvement in students&rsquo; learning of Irish since the last chief inspector&rsquo;s report in 2013.<script type='text/javascript' async src='//landmarkads.mainroll.com/p/inarticle/c/2454512.js?dart_n_story_id=ie_466736&dart_n_section=ie_ireland'></script>
<p>The quality of students&rsquo; learning in subject inspections was judged to be satisfactory or better in 68% of lessons in 2010-12, improving to 79% in 2013-16. Inspectors also noted a higher percentage of lessons that were considered very good and a matching reduction in &lsquo;unsatisfactory&rsquo; lessons.</p>
<p>The proportion of lessons where learning was judged to be very good in Irish was 28%, compared to 34% in English and 41% in Maths. However, in 21% of Irish lessons observed, learning was &ldquo;less than satisfactory&rdquo;.</p>
<p>Overall, the inspector&rsquo;s report found that the quality of teaching in primary schools was generally of a high standard and judged as good or better in between 88% and 94% of schools inspected.</p>
<p>The report also outlines positive findings for post-primary schools. The overall quality of teaching in post-primary schools was evaluated as good or better in between 88% and 94% of lessons.</p>
<p>However, at both primary and second level, inspectors noted that while the overall standards of teaching and learning were good or better, more lessons were &ldquo;good&rdquo; rather than &ldquo;very good&rdquo;.</p>
<p>National Association of Principals and Deputy Principals director Clive Byrne said the results showed that schools deliver when they are given proper investment.</p>
<p>&ldquo;Today&rsquo;s report shows that schools will deliver when they are given the right kind of supports. While today&rsquo;s findings are very encouraging, I am also mindful of the remaining challenges for secondary education,&rdquo; he said.</p>
<p>&ldquo;Curriculum reform at senior cycle is an area where we would like to see more progress so that we build on the improvements outlined in today&rsquo;s chief inspector&rsquo;s report and address those where greater attention is needed.</p>
<p>&ldquo;The current teacher shortage issue is also another area which threatens to undermine quality of education at primary and post-primary levels.&rdquo;</p>
<p>Education Minister Richard Bruton said the report highlights &ldquo;all the good practice that takes place on a daily basis&rdquo; in schools.</p>
<p>&ldquo;The findings from this chief inspector&rsquo;s report, together with positive findings for Ireland in international assessments of reading and mathematics, most recently, the PIRLS 2016 report, affirms that the vision outlined in our &lsquo;Action Plan for Education&rsquo; &mdash; that the Irish education and training system should become the best in Europe over the next decade &mdash; is achievable,&rdquo; he said.</p>
<p class="orangeheader">Maith go&nbsp;leor?</p>
<p><strong>Teaching of Irish:</strong>&nbsp;The report expresses concerns about the teaching of Irish at both levels. Standards in Irish are poorer than those in English and maths, it says.</p>
<p><strong>Primary:</strong>&nbsp;The quality of teaching of Irish remained broadly the same over the period 2013-16, as during 2010-12, and inspectors reported that improvements are required in this area.</p>
<p>The quality of learning in Irish was good or better in 74% of lessons, with learning in 26% of Irish lessons deemed to be&nbsp;unsatis-factory.</p>
<p><strong>Post Primary:</strong>&nbsp;Challenges persist at post-primary level although the quality of students&rsquo; learning in Irish in subject inspections showed an improvement in students&rsquo; learning since the last chief inspector&rsquo;s report.</p>
<p>The quality of students&rsquo; learning in Irish was<br class="HardReturn" />judged to be satisfactory or better in 68% of lessons in 2010-12, and that this<br class="HardReturn" />had improved to 79% in 2013-16.</p>
<p class="orangeheader">Maths and English add up</p>
<p><strong>Teaching&nbsp;of English:</strong></p>
<p><strong>Primary:</strong>&nbsp;There has been an improvement in the quality of teaching and learning of English in primary schools.</p>
<p>The quality of teaching and learning was satisfactory, or better, in 93% of primary schools in 2013-2016, compared to 89% of schools in 2010-2012.</p>
<p><strong>Post Primary:</strong>&nbsp;Learning in English was found to be good, or very good, in 83% of lessons observed in inspections of English.</p>
<p><strong>Teaching of Mathematics:</strong></p>
<p><strong>Primary:</strong>&nbsp;The quality of teaching and learning in mathematics was found to be satisfactory, or better, in 96% of schools, compared to 92% in the 2010-2012 report.</p>
<p><strong>Post Primary:</strong>&nbsp;Overall findings from inspections are largely positive. The data from 2013-2016 shows that learning was good, or better, in 88% of lessons in maths, which is a significant increase, compared to 2010-2012, where the quality of learning was good or better in 74% of lessons.</p></p><script type='text/javascript'>
var ULTIMEDIA_mdtk = '02156613'; 
var ULTIMEDIA_zone= 2; 
var ULTIMEDIA_target = 'ultimedia_wrapper'; 
var ULTIMEDIA_async = false; 
</script>
<script type='text/javascript' src='https://www.ultimedia.com/js/common/smart.js'></script>
</br>
</story></div>
<p></p>
<p class='copyright'><i>&copy; Irish Examiner Ltd. All rights reserved</i></p><div class='share-buttons bottom clearfix'><div class='share-buttons bottom clearfix'><iframe src="https://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.facebook.com%2FIrishExaminer&amp;layout=button_count&amp;show_faces=false&amp;width=90&amp;action=like&amp;font=verdana&amp;colorscheme=light" allowtransparency="true" style="border:medium none; overflow: hidden; width: 100px; height: 21px;" frameborder="0" scrolling="no"></iframe><iframe src="https://platform.twitter.com/widgets/follow_button.html?screen_name=irishexaminer&show_count=false" style="width: 200px; height: 21px;" allowtransparency="true" frameborder="0" scrolling="no"></iframe></div></div><div id="shareSidebar">
<div id='sideShareDiv'>
</div>
</div>
<script type="text/javascript">
var act = new gigya.socialize.UserAction();
act.setLinkBack("http://www.irishexaminer.com/ireland/concern-over-quality-of-irish-teaching-in-schools-466736.html");
act.setTitle("Concern over quality of Irish teaching in schools");
var showShareBarUI_params = {
 containerID: 'sideShareDiv',
shareButtons: [
{provider: 'facebook', tooltip: 'Recommend this on Facebook', iconImgUp:'/images/social/sidebar/facebook-gigya-side.png', iconImgOver: '/images/social/sidebar/facebook-gigya-side-hover.png', iconOnly: true},
{provider: 'twitter', tooltip: 'Share on Twitter', iconImgUp:'/images/social/sidebar/twitter-gigya-side.png', iconImgOver: '/images/social/sidebar/twitter-gigya-side-hover.png',  iconOnly: true},
{provider: 'googleplus', tooltip: 'Share on Google+',  iconImgUp:'/images/social/sidebar/googleplus-gigya-side.png', iconImgOver: '/images/social/sidebar/googleplus-gigya-side-hover.png',  iconOnly: true},
{provider: 'share', tooltip: 'More share options',  iconImgUp:'/images/social/sidebar/more-gigya-side.png', iconImgOver: '/images/social/sidebar/more-gigya-side-hover.png',  iconOnly: true}
],
 layout:  'vertical',
 showCounts:  'none',
 userAction: act };
</script>
<script type="text/javascript">gigya.socialize.showShareBarUI(showShareBarUI_params);</script>
</div><div class='emailupdates'><div class='story-page-footer'><h2 class='email-title'>News Daily Headlines</h2><p class='email-subtext'>Receive our lunchtime briefing straight to your inbox</p><div id='mc_embed_signup' class='subscribe-box-articles'><form action='https://landmarkdigital.us6.list-manage.com/subscribe/post?u=caa589fc19&amp;id=c96f7404b9' method='post' id='mc-embedded-subscribe-form' name='mc-embedded-subscribe-form' class='validate' target='_blank' novalidate=''><input type='email' name='EMAIL' class='email-field' id='mce-EMAIL' placeholder='Your email address...'><input type='submit' value='Sign Me Up' name='subscribe' id='mc-embedded-subscribe' class='go-button'></form></div></div></div> <div class="more-in-this-section"></div><div class='story-page-wrapper'><div class='story-page-footer'><div class='story-page-footer-header'><p class='story-page-footer-title'>Related Articles</p></div><p class='story-page-element-content'><a style='color:black;' title="40% of Irish primary schools are running a deficit just to provide heating and other essential services." href='/breakingnews/ireland/40-of-primary-schools-running-a-deficit-just-to-provide-heating-824898.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/c/ChildrensCoatsHandInClassroom.jpg?width=300&s=ie-824898' />40% of primary schools running a deficit just to provide heating</a></p><p class='story-page-element-content'><a style='color:black;' title="The Education Minister wants to double the number of student teachers." href='/breakingnews/ireland/richard-bruton-wants-to-double-number-of-student-teachers-824892.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/r/RichardBrutonFG.jpg?width=300&s=ie-824892' />Richard Bruton wants to double number of student teachers</a></p><p class='story-page-element-content'><a style='color:black;' title="Worthy further education reforms may be unrealistic without extra funding, writes Education Correspondent Niall Murray." href='/breakingnews/views/solas-shines-a-light-on-reform-of-neglected-plc-sector-821999.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/s/SolasIreland.jpg?width=300&s=ie-821999' />Solas shines a light on reform of neglected PLC sector</a></p><p class='story-page-element-content'><a style='color:black;' title="THAT Ireland&rsquo;s 10-year-olds have the best reading skills in Europe and are among the top-performers in the world is an achievement worth celebrating." href='/breakingnews/views/reading-skills-at-high-watermark-top-of-the-class-817304.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/t/TeacherGenericClassroom.jpg?width=300&s=ie-817304' />Reading skills at high watermark: Top of the class</a></p></div></div><div class='more-in-this-section'></div><div class='story-page-wrapper'><div class='story-page-footer'><div class='story-page-footer-header'><p class='story-page-footer-title'>More in this Section</p></div><p class='story-page-element-content'><a style='color:black' title="The cost of Storm Ophelia is still being counted by students and a local community whose sports hall lost its roof in scenes broadcast around the world." href='/ireland/cork-school-that-lost-gym-roof-in-storm-planning-to-begin-repairs-in-march-466688.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/j/JimLongDouglasCommunitySchool.jpg?width=300&s=ie-466688' />Cork school that lost gym roof in storm planning to begin repairs in March</a></p><p class='story-page-element-content'><a style='color:black' title="The high-tech Ludgate Hub which has brought one-gigabit connectivity to the West Cork town of Skibbereen is set for up to &euro;30,000 in funding, thanks to a partnership with a Cork charity and philanthropic network." href='/ireland/cork-foundation-in-a-bid-to-secure-up-to-30000-for-skibbereens-ludgate-hub-466685.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/a/AdrienneHarringtonPadraicVallelySkibereen.jpg?width=300&s=ie-466685' />Cork Foundation in a bid to secure up to €30,000 for Skibbereen's Ludgate Hub</a></p><p class='story-page-element-content'><a style='color:black' title="Beach lovers and commercial fish farmers are gearing up for a further battle over a planned shoreline industry in Co Kerry." href='/ireland/fish-farming-controversy-continues-in-co-kerry-466684.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/e/exam040114RossbeighAfterStorm.jpg?width=300&s=ie-466684' />Fish farming controversy continues in Co Kerry</a></p><p class='story-page-element-content'><a style='color:black' title="No patients were harmed as a result of a technical problem in the HSE for recording the results of thousands of Xrays and scans, according to a report." href='/ireland/hse-computer-system-failed-to-recognise-symbols-466704.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/d/DoctorWithXRay2016.jpg?width=300&s=ie-466704' />HSE computer system failed to recognise ‘<’ symbols</a></p></div></div><br clear='all'>
<div id="taboola-below-article-thumbnails"></div>
<script type='text/javascript'>window._taboola = window._taboola || [];  _taboola.push({  mode: 'thumbnails-a', container: 'taboola-below-article-thumbnails', placement: 'Below Article Thumbnails', target_type:'mix' }); </script>
<div id='StoryAdsense' data-cb-ad-id='Story_Adsense' class='ad'>
<script type='text/javascript' async src='https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
<ins class='adsbygoogle ie-story-responsive' style='display:inline-block' data-ad-client='ca-pub-2703046863748014' data-ad-slot='8473383144'></ins>
<script type='text/javascript'>(adsbygoogle = window.adsbygoogle || []).push({});</script>
</div>
<div class="more-in-this-section"></div><div class='story-page-wrapper'><div class='story-page-footer'><div class='story-page-footer-header'><p class='story-page-footer-title'>Breaking Stories</p></div><p class='story-page-element-content'><a style='color:black' title="The Rural and Community Development Minister says he believes the new National Development Plan will promote jobs in rural communities." href='/breakingnews/ireland/cork-to-limerick-motorway-and-dublin-airport-included-in-115bn-national-development-plan-826540.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/m/M20CorkLimerickMotorway180717.jpg?width=300&s=ie-826540' />Cork to Limerick motorway and Dublin Airport included in €115bn National Development Plan</a></p><p class='story-page-element-content'><a style='color:black' title="Garda&iacute; are examining claims that members of the force made a joke around missing Cork woman Tina Satchwell but have not yet decided if disciplinary proceedings are warranted or not." href='/breakingnews/ireland/gardai-investigate-joke-at-expense-of-missing-woman-826538.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/t/TinaSatchwellGardaPaulByrneTweetFeb2018.jpg?width=300&s=ie-826538' />Gardaí investigate ‘joke’ at expense of missing woman</a></p><p class='story-page-element-content'><a style='color:black' title="A man is recovering in hospital after being stabbed in Waterford." href='/breakingnews/ireland/man-in-hospital-after-being-stabbed-in-the-head-in-waterford-826518.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/u/UniversityHospitalWaterford090916.jpg?width=300&s=ie-826518' />Man in hospital after being stabbed in the head in Waterford</a></p><p class='story-page-element-content'><a style='color:black' title="The DUP has said 'huge differences' still remain to be resolved before powersharing at Stormont can be restored." href='/breakingnews/ireland/huge-differences-remain-to-be-resolved-in-stormont-talks-dup-warns-826516.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/c/CaralNiChuilinMeganFearonDeclanKearneyConorMurphySFFeb2018.jpg?width=300&s=ie-826516' />'Huge differences' remain to be resolved in Stormont talks, DUP warns</a></p></div></div><div class="more-in-this-section"></div><div class='story-page-wrapper'><div class='story-page-footer'><div class='story-page-footer-header'><p class='story-page-footer-title'>Lifestyle</p></div><p class='story-page-element-content'><a style='color:black' title="It&rsquo;s the biggest cancer killer, and yet 27% of Irish people can&rsquo;t name one symptom of lung cancer. This Lung Cancer Awareness Month, Ellie O&rsquo;Byrne talks to a couple all too familiar with the disease, and with a researcher dedicated to improving patients&rsquo; outcomes." href='/lifestyle/features/the-biggest-cancer-killer-will-take-your-breath-away-465906.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/l/LungCancerPaper170118.jpg?width=300&s=ie-465906' />The biggest cancer killer will take your breath away</a></p><p class='story-page-element-content'><a style='color:black' title="Unknown in 1991, Dolores O&rsquo;Riordan was soon fronting one of the biggest band in the world, writes Joyce Fegan" href='/lifestyle/features/hopefully-she-had-an-idea-465836.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/d/DoloresORiordanPerforming150118.jpg?width=300&s=ie-465836' />Hopefully she had an idea...</a></p><p class='story-page-element-content'><a style='color:black' title="Through accident and design, Spielberg couldn&rsquo;t have timed The Post better, writesShilpa Ginatra" href='/lifestyle/artsfilmtv/power-of-the-press-meryl-streep-and-tom-hanks-discuss-the-post-465817.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/t/tomhanksmerylstreepthepost.jpg?width=300&s=ie-465817' />Power of the press: Meryl Streep and Tom Hanks discuss 'The Post'</a></p></div></div><div class='more-from'><p>More From The Irish Examiner</p><ul class='double-image'><li><a href='/frontpages/'><img src='/images/shop/front-page-prints-659x355.jpg' /></a></li><li><a href='http://photos.examiner.ie/'><img src='/images/shop/photosalesnew-659x355.jpg' /></a></li><li><a href="https://www.irishexaminer.com/epaper/"> <img src='/images/shop/epaper2-659x355.jpg' /></a></li><li><a href='/archive/'> <img src='/images/shop/659x355_digitalarchive.jpg' /></a></li></ul></div></div>
<div class="col-middle">
</div>
<div class="col-right">


<div class="sidebar-unit stickyad2" id="top-mpu-ad">
<center><div id='MPUTop' data-cb-ad-id='MPU_Top' class='ad'><div id='div-gpt-ad-1346688247801-2'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-2');googletag.pubads().refresh([n_ie_mpu_start_300x250]);});</script></div></div></center>
</div>

<div id='div-gpt-ad-1479983964240-0'>
<script type='text/javascript'>
                        googletag.cmd.push(function () { 
                            googletag.display('div-gpt-ad-1479983964240-0');
                            googletag.pubads().refresh([n_ie_marketing_mpu]); 
                        });
                    </script>
</div>

<div class="sidebar-unit">
</div>
<div class="sidebar-unit">
<a href='/examviral'><img src='/images/exam_viral_300x50.jpg' /></a><div class='sidebar-unit'><div class='most-read'><div class='text-body'><div class='tab-content'><div class='tab-pane active' id='mostread'><ul data-vr-zone='most-read-stories'><li data-vr-contentbox=''><a href='/examviral/world-nutella-day-12-of-the-most-indulgent-ways-you-can-eat-the-spread-826531.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2018/02/05113434/b44bec00-3948-4b5e-8428-d433d9e459b6.jpg?crop=0,133,2123,1327&ext=.jpg&width=300&s=ie-826531" width="300" height="160" /></a><a href='/examviral/world-nutella-day-12-of-the-most-indulgent-ways-you-can-eat-the-spread-826531.html'>World Nutella Day: 12 of the most indulgent ways you can eat the spread</a><li data-vr-contentbox=''><a href='/examviral/10-hilariously-unfortunate-email-typos-826506.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2018/02/05171005/d8376d41-2a1b-49a2-8fed-73406bb7c916.jpg?crop=0,250,3999,2499&ext=.jpg&width=300&s=ie-826506" width="300" height="160" /></a><a href='/examviral/10-hilariously-unfortunate-email-typos-826506.html'>10 hilariously unfortunate email typos</a><li data-vr-contentbox=''><a href='/examviral/absolute-chaos-as-eagles-fans-swoop-onto-streets-of-philadelphia-826492.html'><img itemprop="image" src="/remote/media.central.ie/media/images/s/SuperBowl18b.jpg?width=300&s=ie-826492" width="300" height="160" /></a><a href='/examviral/absolute-chaos-as-eagles-fans-swoop-onto-streets-of-philadelphia-826492.html'>Absolute chaos as Eagles fans swoop onto streets of Philadelphia</a><li data-vr-contentbox=''><a href='/examviral/making-a-murderer-attorney-to-lecture-ul-law-students-826466.html'><img itemprop="image" src="/remote/media.central.ie/media/images/d/DeanStrangJan16.jpg?width=300&s=ie-826466" width="300" height="160" /></a><a href='/examviral/making-a-murderer-attorney-to-lecture-ul-law-students-826466.html'>‘Making A Murderer’ attorney to lecture UL law students</a><li data-vr-contentbox=''><a href='/examviral/patients-grandson-buys-200-bottles-of-water-to-help-ease-hospital-leak-crisis-826465.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2018/02/05125651/7f1f583c-7355-404a-b907-785257d757aa.jpg?crop=0,0,1920,1080&ext=.jpg&width=300&s=ie-826465" width="300" height="160" /></a><a href='/examviral/patients-grandson-buys-200-bottles-of-water-to-help-ease-hospital-leak-crisis-826465.html'>Patient’s grandson buys 200 bottles of water to help ease hospital leak crisis</a><li data-vr-contentbox=''><a href='/examviral/these-are-the-super-bowl-2018-adverts-that-got-people-talking-826460.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2018/02/05132024/a57cd1e3-bd7a-4420-8392-67d79bd75aeb.jpg?crop=0,0,1902,1070&ext=.jpg&width=300&s=ie-826460" width="300" height="160" /></a><a href='/examviral/these-are-the-super-bowl-2018-adverts-that-got-people-talking-826460.html'>These are the Super Bowl 2018 adverts that got people talking</a></ul></div></div></div></div></div><form name="aspnetForm" method="post" action="./concern-over-quality-of-irish-teaching-in-schools-466736.html?sid=466736&amp;h=concern-over-quality-of-irish-teaching-in-schools&amp;t=html" id="aspnetForm">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />

<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="8202156D" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/wEdAATYVglT91cZDrfenc9b4R+Kfgivf6waS+P2vDk5sTHDJ1vWujcrRo5LJaXsi8T4nk+SKGRakVEtPAXcscbjmEe2qbD0vdpKHBMw2X3JebrEgNgokoA=" />
 <br />
    <div class="ri_container">
		<div class="ri_background">
			<div class="ri_logo">
				<img class="ri" src="https://media.irishexaminer.com/marketing/recruitirelandlogo.png" />
			</div>
			<div class="ri_title">
				<h2>Start the search</h2>
			</div>
			<div class="ri_divider">

			</div>
			<div class="ri_sub_title">
				<p>for your new job</p>
			</div>
			<div class="controls">
				<div class="input-box">
                        <input name="ctl00$fpTextbox" type="text" id="ctl00_fpTextbox" placeholder="e.g. engineer" />
                   	</div>
				<div class="input-box">
					   <select name="ctl00$fbSelect" id="ctl00_fbSelect">
	<option selected="selected" value="">All Regions</option>
	<option value="Dublin County">Dublin</option>
	<option value="Cork">Cork</option>
	<option value="Limerick">Limerick</option>
	<option value="Galway">Galway</option>
	<option value="---------------------">---------------------</option>
	<option value="Dublin County">Dublin</option>
	<option value="Dublin North">Dublin North</option>
	<option value="Dublin South">Dublin South</option>
	<option value="Dublin West">Dublin West</option>
	<option value="Dublin City Centre">Dublin City Centre</option>
	<option value="Antrim">Antrim</option>
	<option value="Armagh">Armagh</option>
	<option value="Carlow">Carlow</option>
	<option value="Cavan">Cavan</option>
	<option value="Clare">Clare</option>
	<option value="Cork">Cork</option>
	<option value="Derry">Derry</option>
	<option value="Donegal">Donegal</option>
	<option value="Down">Down</option>
	<option value="Fermanagh">Fermanagh</option>
	<option value="Galway">Galway</option>
	<option value="Kerry">Kerry</option>
	<option value="Kildare">Kildare</option>
	<option value="Kilkenny">Kilkenny</option>
	<option value="Laois">Laois</option>
	<option value="Leitrim">Leitrim</option>
	<option value="Limerick">Limerick</option>
	<option value="Longford">Longford</option>
	<option value="Louth">Louth</option>
	<option value="Mayo">Mayo</option>
	<option value="Meath">Meath</option>
	<option value="Monaghan">Monaghan</option>
	<option value="Offaly">Offaly</option>
	<option value="Roscommon">Roscommon</option>
	<option value="Sligo">Sligo</option>
	<option value="Tipperary">Tipperary</option>
	<option value="Tyrone">Tyrone</option>
	<option value="Waterford">Waterford</option>
	<option value="Westmeath">Westmeath</option>
	<option value="Wexford">Wexford</option>
	<option value="Wicklow">Wicklow</option>
	<option value="---------------------">---------------------</option>
	<option value="Rest of Leinster">Rest of Leinster</option>
	<option value="Munster">Munster</option>
	<option value="Connaught/Ulster">Connaught/Ulster</option>
	<option value="Northern Ireland">Northern Ireland</option>
	<option value="Nationwide">Nationwide</option>
	<option value="---------------------">---------------------</option>
	<option value="UK">UK</option>
	<option value="Europe">Europe</option>
	<option value="Worldwide">Worldwide</option>
	<option value="Australia">Australia</option>
	<option value="United Arab Emirates">United Arab Emirates</option>
	<option value="New Zealand">New Zealand</option>
	<option value="Canada">Canada</option>
	<option value="USA">USA</option>
	<option value="North Africa">North Africa</option>
	<option value="South Africa">South Africa</option>
	<option value="Middle East">Middle East</option>
</select>
					<div class="triangle"></div>
				</div>
				<a id="ctl00_sBTN" class="icon-search test" title="GO" href="javascript:__doPostBack(&#39;ctl00$sBTN&#39;,&#39;&#39;)">GO</a>
			</div>

		</div>
	</div>
               </form>



                </div>


                
                
                    <!--Lotto -->
                    <div class="sidebar-unit">




                        <div class='lottos-right-side clearfix'>
<h2 class='lotto-bold-header-right-side'>Lotto Results</h2><h2>Saturday, February 03, 2018</h2>
<ul class='lotto-results-widget-right-side clearfix'><ul class='lotto-numbers-widget-right-side'><li><span class='lotto-number-widget-right-side blue'>7</span></li>
<li><span class='lotto-number-widget-right-side orange'>16</span></li>
<li><span class='lotto-number-widget-right-side green'>21</span></li>
<li><span class='lotto-number-widget-right-side blue'>27</span></li>
<li><span class='lotto-number-widget-right-side red'>30</span></li>
<li><span class='lotto-number-widget-right-side blue'>31</span></li>
<li class='last-right-side'><span class='lotto-number-widget-right-side red'>26<span aria-hidden='true' class='icon-star-right-side'></span></span></li>
</ul></ul>
<h3><a title='Full Lotto draw results' href='/lotto/' class='more-results-right-side'>Full Lotto draw results &raquo;</a></h3>
</div>

                    </div>
                
                    <div class="sidebar-unit">
                        <div class="s-block follow-ie">
<h2>
      Follow the Irish Examiner
    </h2>
    <p>

    
      <!--<a href="http://twitter.com/irishexaminer" title="Twitter"><span class="icon-twitter"></span></a>
      <a href="http://www.facebook.com/irishexaminer" title="Facebook"><span class="icon-facebook"></span></a>
      <a href="https://plus.google.com/u/0/b/111234426392903310445/"><span class="icon-googleplus"></span></a>
      <a href="http://www.youtube.com/irishexaminer" title="Youtube"><span class="icon-youtube"></span></a>
      <a href="http://storify.com/IrishExaminer" title="Storify"><span class="icon-storyfy"></span></a>
      <a href="/competitions/sign-up-to-our-newsletter-11.html" title="Newsletter"><span class="icon-mail"></span></a>-->
        <a title="Twitter" href="http://twitter.com/irishexaminer"><span class="icon-twitter"></span></a>
        <a title="Facebook" href="http://www.facebook.com/irishexaminer"><span class="icon-facebook"></span></a>
        <a href="https://www.instagram.com/irish_examiner/" target="_blank"><span class="icon-instagram"></span></a>
        <a title="Youtube" href="http://www.youtube.com/irishexaminer"><span class="icon-youtube"></span></a>
        <a href="http://www.irishexaminer.com/info/whatsapp/" target="_blank" title="Whatsapp"><span class="icon-whatsapp" target="_blank"></span></a>
        <a title="Newsletter" href="/competitions/sign-up-to-our-newsletter-11.html"><span class="icon-mail"></span></a>
        <a title="Snapchat" href="https://www.snapchat.com/add/irishexaminer" target="_blank"><span class="icon-Snapchat"></span></a>




  </p>
  </div>

                    </div>
                
    <!--most read -->
    <!--most read -->
<div class="sidebar-unit">

    <div class="most-read">
        <ul class="tab-header">
            <li class="active"><a data-toggle="tab" href="#mostread">Most Read</a> </li>
            <li><a data-toggle="tab" href="#topstories">Top Stories</a> </li>
            
        </ul>
        <div class="text-body">
            <div class="tab-content">
                <div class="tab-pane active" id="mostread"> <ul data-vr-zone="most-read-stories"><li data-vr-contentbox=""><a href='/breakingnews/ireland/latest-up-to-3cm-of-snow-expected-to-fall-across-the-country-tomorrow-826292.html'><img itemprop="image" src="/remote/media.central.ie/media/images/s/snowfootprints.jpg?width=300&s=ie-826292" width="120" height="64" /></a><a href='/breakingnews/ireland/latest-up-to-3cm-of-snow-expected-to-fall-across-the-country-tomorrow-826292.html'>Latest: Up to 3cm of snow expected to fall across the country tomorrow</a><br/></li><li data-vr-contentbox=""><a href='/breakingnews/ireland/sinn-fein-rocked-by-another-bitter-internal-party-row--leading-td-censured-and-councillor-suspended-826318.html'><img itemprop="image" src="/remote/media.central.ie/media/images/c/CllrNoeleenReilly.jpg?width=300&s=ie-826318" width="120" height="64" /></a><a href='/breakingnews/ireland/sinn-fein-rocked-by-another-bitter-internal-party-row--leading-td-censured-and-councillor-suspended-826318.html'>Sinn Féin rocked by another bitter internal party row -  leading TD censured and councillor suspended</a><br/></li><li data-vr-contentbox=""><a href='/breakingnews/lifestyle/corks-oldest-airbnb-superhost-shares-his-secret-826310.html'><img itemprop="image" src="/remote/media.central.ie/media/images/i/IanStretchAirBnBSitting4Feb2018.jpg?width=300&s=ie-826310" width="120" height="64" /></a><a href='/breakingnews/lifestyle/corks-oldest-airbnb-superhost-shares-his-secret-826310.html'>Cork's oldest Airbnb 'superhost' shares his secret</a><br/></li><li data-vr-contentbox=""><a href='/sport/columnists/donal-lenihan/after-the-euphoria-some-difficult-questions-remain-466706.html'><img itemprop="image" src="/remote/media.central.ie/media/images/j/JoeSchmidtIrelandPresserMar18.jpg?width=300&s=ie-466706" width="120" height="64" /></a><a title='After a worrying Six Nations losing streak on the road, with only one championship success in the last five away fixtures &mdash; and that against Italy in Rome lastseason &mdash; Joe Schmidt cut a mightily relieved man to have got this opening win in Paris under his belt.' href='/sport/columnists/donal-lenihan/after-the-euphoria-some-difficult-questions-remain-466706.html'>After the euphoria, some difficult questions remain</a></li><li data-vr-contentbox=""><a href='/breakingnews/sport/ronan-ogara-and-ruby-walsh-tackle-sports-topics-in-front-of-cork-audience-826384.html'><img itemprop="image" src="/remote/media.central.ie/media/images/r/RonanOGaraBreakfastOfChampionsDanLineham050218.jpg?width=300&s=ie-826384" width="120" height="64" /></a><a href='/breakingnews/sport/ronan-ogara-and-ruby-walsh-tackle-sports-topics-in-front-of-cork-audience-826384.html'>Ronan O’Gara and Ruby Walsh tackle sports topics in front of Cork audience</a><br/></li><li data-vr-contentbox=""><a href='/breakingnews/business/cork-firm-looking-for-new-staff-offer-food-travel-and-wellbeing-bonuses-826268.html'><img itemprop="image" src="/remote/media.central.ie/media/images/e/Eventbrite170216.jpg?width=300&s=ie-826268" width="120" height="64" /></a><a href='/breakingnews/business/cork-firm-looking-for-new-staff-offer-food-travel-and-wellbeing-bonuses-826268.html'>Cork firm looking for new staff offer food, travel and wellbeing bonuses</a><br/></li><li data-vr-contentbox=""><a href='/breakingnews/ireland/motorists-urged-to-take-precautions-as-survey-reveals-nearly-a-third-of-cars-vandalised-826295.html'><img itemprop="image" src="/remote/media.central.ie/media/images/c/CarsOnABusyMotorway010118.jpg?width=300&s=ie-826295" width="120" height="64" /></a><a href='/breakingnews/ireland/motorists-urged-to-take-precautions-as-survey-reveals-nearly-a-third-of-cars-vandalised-826295.html'>Motorists urged to take precautions as survey reveals nearly a third of cars vandalised</a><br/></li><li data-vr-contentbox=""><a href='/breakingnews/ireland/calls-for-cork-skyscraper-plans-to-be-scrapped-826392.html'><img itemprop="image" src="/remote/media.central.ie/media/images/c/corkskyscraperrender.jpg?width=300&s=ie-826392" width="120" height="64" /></a><a href='/breakingnews/ireland/calls-for-cork-skyscraper-plans-to-be-scrapped-826392.html'>Calls for Cork skyscraper plans to be scrapped</a><br/></li><li data-vr-contentbox=""><a href='/breakingnews/ireland/gardai-investigating-harvey-weinstein-in-connection-with-alleged-dublin-assault-826399.html'><img itemprop="image" src="/remote/media.central.ie/media/images/h/HarveyWeinstein2012Getty.jpg?width=300&s=ie-826399" width="120" height="64" /></a><a href='/breakingnews/ireland/gardai-investigating-harvey-weinstein-in-connection-with-alleged-dublin-assault-826399.html'>Gardaí investigating Harvey Weinstein in connection with alleged Dublin assault</a><br/></li><li data-vr-contentbox=""><a href='/breakingnews/ireland/man-who-had-sex-with-15-year-old-schoolgirl-jailed-for-two-years-808321.html'><img itemprop="image" src="/remote/media.central.ie/media/images/c/centralCriminalCourt.jpg?width=300&s=ie-808321" width="120" height="64" /></a><a href='/breakingnews/ireland/man-who-had-sex-with-15-year-old-schoolgirl-jailed-for-two-years-808321.html'>Man who had sex with 15 year old schoolgirl jailed for two years </a><br/></li></ul></div>
                <div class="tab-pane" id="topstories"><ul data-vr-zone="top-stories"><li data-vr-contentbox="" class="ts-headline"><b>NEWS</b></li><li data-vr-contentbox=""><a href='/ireland/hse-computer-system-failed-to-recognise-symbols-466704.html'><img itemprop="image" src="/remote/media.central.ie/media/images/d/DoctorWithXRay2016.jpg?width=300&s=ie-466704" width="120" height="64" /></a><a title='No patients were harmed as a result of a technical problem in the HSE for recording the results of thousands of Xrays and scans, according to a report.' href='/ireland/hse-computer-system-failed-to-recognise-symbols-466704.html'>HSE computer system failed to recognise ‘<’ symbols</a></li><li data-vr-contentbox=""><a href='/ireland/50000-awaiting-eye-treatments-many-of-them-for-18-months-466689.html'><img itemprop="image" src="/remote/media.central.ie/media/images/e/EyeTestDoctor.jpg?width=300&s=ie-466689" width="120" height="64" /></a><a title='Some 50,000 people were on waiting lists for eye procedures at the end of last year, many of them for 18 months.' href='/ireland/50000-awaiting-eye-treatments-many-of-them-for-18-months-466689.html'>50,000 awaiting eye treatments, many of them for 18 months</a></li><li data-vr-contentbox="" class="ts-headline"><b>SPORT</b></li><li data-vr-contentbox=""><a href='/sport/columnists/john-fogarty/one-mans-cheat-is-another-mans-chance-466732.html'><img itemprop="image" src="/remote/media.central.ie/media/images/l/LeeKeeganCiaranKilkennyfightafterwinningscoreDublinvMayoSep17.jpg?width=300&s=ie-466732" width="120" height="64" /></a><a title='The strength of Kerry selector Mikey Sheehy&rsquo;s commentary last month about the county&rsquo;s paltry numbers at last August&rsquo;s All-Ireland semi-final replay meant his remarks about cynical play went largely unnoticed, writesJohn Fogarty.' href='/sport/columnists/john-fogarty/one-mans-cheat-is-another-mans-chance-466732.html'>One man’s cheat is another man’s chance</a></li><li data-vr-contentbox=""><a href='/sport/columnists/mike-quirke/nobodys-griping-about-football-now-nor-its-subscription-channel-coverage-466733.html'><img itemprop="image" src="/remote/media.central.ie/media/images/m/MayoVKerryBrendanHarrisonPaulGeaney.jpg?width=300&s=ie-466733" width="120" height="64" /></a><a title='We&rsquo;re all paying forEir,because our national broadcaster didn&rsquo;t have the foresight or desire to recognise and harness the obvious potential of the National League, writesMike Quirke.' href='/sport/columnists/mike-quirke/nobodys-griping-about-football-now-nor-its-subscription-channel-coverage-466733.html'>Nobody’s griping about football now, nor its subscription channel coverage</a></li></ul></div>
            
            </div>
        </div>
    </div>

</div>

    <!--most read -->


                    <div class="sidebar-unit mpu" id="bot-mpu-ad">
                        <!-- MPU end goes in right col on non-mobile version -->
                        
                            <center>
                                <!-- IE_ie_ireland_MPU_End_300x250 --><div id='MPUEnd' data-cb-ad-id='MPU_End' class='ad'><div id='div-gpt-ad-1346688247801-1'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-1');googletag.pubads().refresh([n_ie_mpu_end_300x250]);});</script></div></div></center>
                        
                    </div>

                    
                

                <!-- end of rightColumnToHide --->
            



        </div>
    </div>
    </div>
    
    
        <footer><div class="container">
    <div class="foot-nav">
        <div class="foot-logos">
            <a href="http://www.nni.ie">
                <img src="/assets/images/layout/f-logo1.png" /></a><a href="http://www.presscouncil.ie"><img
                    src="/assets/images/layout/f-logo2.png" /></a>
        </div>
    </div>
    <div class="foot-nav">
        <span>News</span>
        <ul>
            <li><a href="/breakingnews/">Breaking News</a></li>
            <li><a href="/ireland/">Today&acute;s Paper</a></li>
            <li><a href="/breakingnews/world/">World</a></li>
            <li><a href="/business/">Business</a></li>
            <li><a href="/breakingnews/farming/">Farming</a></li>
            <li><a href="/breakingnews/technow/">Technology</a></li>
            <li><a href="/weather/">Weather</a></li>
            <li><a href="/deathnotices/">Death Notices</a></li>
            <li><a href="/archives/">Archives</a></li>
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/sport/">Sport</a></span>
        <ul>
            <li><a href="/sport/soccer/">Soccer</a></li>
            <li><a href="/sport/podcast/">Podcast</a></li>
            <li><a href="/sport/columnists/">Columnists</a></li>
            <li><a href="/sport/gaa/">GAA</a></li>
            <li><a href="/sport/rugby/">Rugby</a></li>
            <li><a href="/sport/golf/">Golf</a></li>
            <li><a href="/sport/racing/">Racing</a></li>
            <li><a href="/sport/other-sports/">Other Sport</a></li>
            <li><a href="/sport/results/">Results</a></li>
            <!--<li><a href="/rwc15/">RWC 2015</a></li>-->
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/viewpoints/">Viewpoints</a></span>
        <ul>
            <li><a href="/viewpoints/ourview/">Our view (editorial)</a></li>
            <li><a href="/viewpoints/yourview/">Your view (letters)</a></li>
            <li><a href="/viewpoints/letters/sendletter">Send letter to editor's page</a></li>
            <li><a href="/columnists/">Columnists</a></li>
       </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/property/">Property</a></span>
        <ul>
            <li><a href="/property/news/">News</a></li>
            <li><a href="/property/houseofweek/">House of the Week</a></li>
            <li><a href="/property/coverstory/">Cover Story</a></li>
            <li><a href="/property/commercial/">Commercial</a></li>
            <li><a href="/property/starterhomes/">Starter Homes</a></li>
            <li><a href="/property/tradingup/">Trading Up</a></li>
            <li><a href="/property/features/">Features</a></li>
            <li><a href="http://property.examiner.ie">Property Search</a></li>
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/lifestyle/">Lifestyle</a></span>
        <ul>
            <li><a href="/breakingnews/entertainment/">Showbiz</a></li>
            <li><a href="/breakingnews/lifestyle/fashionandbeauty/">Fashion &amp; Beauty</a></li>
            <li><a href="/breakingnews/lifestyle/foodanddrink/">Food &amp; Drink</a></li>
            <li><a href="/breakingnews/lifestyle/healthandlife/">Health &amp; Life</a></li>
            <li><a href="/breakingnews/lifestyle/homeandinteriors/">Home &amp; Interiors</a></li>
            <li><a href="/lifestyle/horoscopes/">Horoscopes</a></li>
            <li><a href="/breakingnews/lifestyle/travel/">Travel</a></li>
            <li><a href="/breakingnews/lifestyle/artsfilmtv/">Arts, Books, Film & TV</a></li>
            <li><a href="/breakingnews/lifestyle/features/">Features</a></li>
            <li><a href="/motors/">Motors</a></li>
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/info/help/">Help</a></span>
        <ul>
            <li><a href="/info/faq/">FAQ</a></li>
            <li><a href="/info/contactus/">Contact Us</a></li>
            <li><a href="/info/mediapack/">Media Pack</a></li>
            <li><a href="/info/privacypolicy/">Privacy Policy</a></li>
            <li><a href="/info/cookiepolicy/">Cookie Policy</a></li>
            <li><a href="/getmobile/">Mobile</a></li>
            <li><a href="/info/subscriptions/">Subscriptions</a></li>
        
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/info/help/">Info</a></span>
        <ul>
            <li><a href="/info/terms/">Terms and Conditions</a></li>
            <li><a href="http://www.nni.ie">NNI</a></li>
            <li><a href="/epaper/">ePaper</a></li>
            <li><a href="/info/postaldeliveryenquiry/">Postal Delivery</a></li>
            <li><a href="/competitions/">Competitions</a></li>
            <li><a href="/info/syndication/">RSS</a></li>
        </ul>
    </div>


    <p>
        &copy; Irish Examiner Ltd, Linn Dubh, Assumption Road, Blackpool, Cork. Registered
        in Ireland: 523712.</p>
</div>
</footer>
    

    

    <!-- (advertising -usually to hold 1x1 pixel ad) -->
    <!-- n_ie_placeholder_1x1 --><div id='div-gpt-ad-1346688247801-12' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-12');googletag.pubads().refresh([n_ie_placeholder_1x1 ]);});</script></div><div id='imageDiv1x1'></div><!-- placeholder_2x2 --><div id='div-gpt-ad-1346688247801-3' style='width:2px; height:2px;'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-3');googletag.pubads().refresh([n_ie_placeholder_2x2 ]);});</script></div>
    
    
    
<script type='text/javascript'>
var _sf_async_config = _sf_async_config || {};
_sf_async_config.sections = 'Ireland,';
_sf_async_config.authors = 'Conall Ó Fátharta';
_sf_async_config.zone = 'Ireland';

(function () {
function loadChartbeat() {
	window._sf_endpt = (new Date()).getTime();
	var e = document.createElement('script');
	e.setAttribute('language', 'javascript');
	e.setAttribute('type', 'text/javascript');
	e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_pub.js');
	document.body.appendChild(e);
	}
var oldonload = window.onload;
window.onload = (typeof window.onload != 'function') ?
	loadChartbeat : function() {
		oldonload();
		loadChartbeat();
	};
})();
</script>

   
    <script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
</body>
</html>
