
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html>
<head id="ctl00_Head1">
<script type='text/javascript'>        var_sf_startpt = (new Date()).getTime()</script>
<meta name="robots" content="noarchive" /><meta content="IE=edge,chrome=1" http-equiv="X-UA-Compatible" /><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info = {"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"7f3747c05c","applicationID":"2084172","transactionName":"YlBWN0ZWWEAAUkEKXlsadTBkGFRBBFBeCl9SW1EURxhSVgdQQA9FG1RHE0w=","queueTime":0,"applicationTime":10,"ttGuid":"2A0DAED2350C685B","agent":""}</script><script type="text/javascript">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</script><meta name="viewport" content="initial-scale=1,maximum-scale=1,user-scalable=no" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Top Stories" href="//feeds.examiner.ie/ietopstories" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Ireland" href="//feeds.examiner.ie/ieireland" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Sport" href="//feeds.examiner.ie/iesport" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: World" href="//feeds.examiner.ie/ieworld" />
<link rel="alternate" type="application/rss+xml" title="IrishExaminer.com: Business" href="//feeds.examiner.ie/iebusiness" />
<meta property="fb:app_id" content="1567359720193705" /><meta property="fb:pages" content="175322202485450" />
<title>
        Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire | Irish Examiner</title>
<link href="/assets/css/app.min.css" media="screen" rel="stylesheet" type="text/css" />
<script type="text/javascript" src="/assets/js/lbp.min.js"></script>
<script type="text/javascript" src="/assets/js/head.min.js"></script>
<script type="text/javascript">
        head.js({ jquery: '//ajax.googleapis.com/ajax/libs/jquery/1/jquery.min.js' }, { modernizr: '/assets/js/modernizr.min.js' }, { all: '/assets/js/all.js' }, { homescreen: '/assets/js/addtohomescreen.min.js' }, { login: '/js/login.js' }, { updatePage: '/js/updateDetails.js' }, { stickyads: '/assets/js/stickyads.min.js' });
    </script>

<script type="text/javascript" src="//native.sharethrough.com/assets/sfp.js"></script>

<script type="text/javascript" src="//cdns.gigya.com/js/gigya.js?apiKey=3_VvF1UthGmxN4wtFIlgliEKHP3VTywNTuqe1saB-DqNTlwgUjZ4zejDQ1beegQt-J">
    {
	    siteName: 'irishexaminer.com (Irish Examiner)'
	    ,enabledProviders: 'facebook,twitter,googleplus,linkedin'
    }
    </script>
<script type="text/javascript">
            head.js({ galleria: '/assets/galleria/galleria-1.4.2.min.js' }, { bbw: '//landmark.bbvms.com/launchpad/' }, { bbwplay: '/assets/bbw/player.min.js' });
        </script>



<meta name="description" content="Headline Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire" />
<link rel="image_src" href="http://media.irishexaminer.com/default/ie_generic_bn.png" />
<meta prefix='og: http://ogp.me/ns#' property="og:type" content="article" />
<meta prefix='og: http://ogp.me/ns#' property="og:url" content="http://www.irishexaminer.com/breakingnews/business/sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire-814697.html">
<meta prefix='og: http://ogp.me/ns#' property="og:image" content="http://media.irishexaminer.com/default/ie_generic_bn.png" />
<meta prefix='og: http://ogp.me/ns#' property="og:image:width" content="600" />
<meta prefix='og: http://ogp.me/ns#' property="og:image:height" content="325" />
<meta prefix='og: http://ogp.me/ns#' property="og:title" content="Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire" />
<meta prefix='og: http://ogp.me/ns#' property="og:description" content="Twenty-First Century Fox shares jumped in US trading and Sky shares rose in London after sources said both Comcast and Verizon Communications were also interested in buying parts of its studio and TV operations." />
<meta property="article:published_time" content="2017-11-18T07:30:00+00" />
<meta property="article:tag" content="business" />
<meta property="article:section" content="business" />
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@irishexaminer">
<meta name="twitter:title" content="Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire" />
<meta name="twitter:url" content="http://www.irishexaminer.com/breakingnews/business/sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire-814697.html">
<meta name="twitter:description" content="Twenty-First Century Fox shares jumped in US trading and Sky shares rose in London after sources said both Comcast and Verizon Communications were also interested in buying parts of its studio and TV operations." />
<meta name="twitter:image" content="http://media.irishexaminer.com/default/ie_generic_bn.png" />
<link rel="canonical" href="http://www.irishexaminer.com/breakingnews/business/sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire-814697.html" />
<link rel="amphtml" href="http://amp.irishexaminer.com/breakingnews/business/sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire-814697.html" />
<script type="text/javascript">
dataLayer = [{"pageType":"Article","pageTitle":"Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire","pageCategory1":"business","pageCategory2":"","pageCategory3":"","pageAttributes":{"comments":"on","images":"1","youtube":"0","twitter":"0","facebook":"0","soundcloud":"0","doccloud":"0"},"pageArticleID":"814697","pageAuthorID":"Irish Examiner","pageArticleHour":"07","pageSource":"ie_iestaff","pageKeywords":["None"]}];
</script>
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function () {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
            })();
        </script>

<script type='text/javascript'>
googletag.cmd.push(function() {
n_ie_leader_728x90 = googletag.defineSlot('/1005055/n_ie_leader_728x90', [[728, 90],[970, 250],[970, 90]], 'div-gpt-ad-1346688247801-0').addService(googletag.pubads());
n_ie_banner_650x90 = googletag.defineSlot('/1005055/n_ie_banner_650x90', [650, 90], 'div-gpt-ad-1468573711486-0').addService(googletag.pubads());
n_ie_placeholder_1x1 = googletag.defineSlot('/1005055/n_ie_placeholder_1x1', [1, 1], 'div-gpt-ad-1346688247801-12').addService(googletag.pubads());
n_ie_placeholder_2x2 = googletag.defineSlot('/1005055/n_ie_placeholder_2x2', [1, 1], 'div-gpt-ad-1346688247801-3').addService(googletag.pubads());
n_ie_marketing_298x73 = googletag.defineSlot('/1005055/n_ie_marketing_298x73', [298, 73], 'div-gpt-ad-1346688247801-4').addService(googletag.pubads());
n_ie_marketing_mpu = googletag.defineSlot('/1005055/n_ie_marketing_mpu', [300, 250], 'div-gpt-ad-1479983964240-0').addService(googletag.pubads());
n_ie_mpu_end_300x250 = googletag.defineSlot('/1005055/n_ie_mpu_end_300x250', [[300, 250],[300, 600]], 'div-gpt-ad-1346688247801-1').addService(googletag.pubads());
n_ie_mpu_start_300x250 = googletag.defineSlot('/1005055/n_ie_mpu_start_300x250', [[300, 250],[300, 600]], 'div-gpt-ad-1346688247801-2').addService(googletag.pubads());
n_ie_sharethrough_instory_2x1 = googletag.defineSlot('/1005055/n_ie_sharethrough_instory_2x1', [2, 1], 'div-gpt-ad-1495459500257-0').addService(googletag.pubads()).setTargeting('strnativekey','rgLt2mjz7xQaDGWA7xxhVwjK');
n_ie_sharethrough_2x1_1 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-1').addService(googletag.pubads());
n_ie_sharethrough_2x1_2 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-2').addService(googletag.pubads());
n_ie_sharethrough_2x1_3 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-3').addService(googletag.pubads());
n_ie_sharethrough_2x1_4 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-4').addService(googletag.pubads());
n_ie_sharethrough_2x1_5 = googletag.defineSlot('/1005055/n_ie_sharethrough_2x1', [2, 1], 'sharethroughAd-5').addService(googletag.pubads());
googletag.pubads().setTargeting('strnativekey','CwbKs52hkbo573Q9KzUoxJEt');
googletag.pubads().setTargeting('n_section', 'ie_business_bn');
googletag.pubads().setTargeting('n_channel', 'storypage');
googletag.pubads().setTargeting('n_passback', 'false');

    googletag.pubads().setTargeting('n_story_id', 'bn_814697');
googletag.pubads().setTargeting('n_keywords', ['inskin_yes','None']);
    var fn_pageskin = 'false'; if (screen.width >= 375) { fn_pageskin = 'true'; }
    googletag.pubads().setTargeting('inskin', fn_pageskin);
googletag.pubads().setTargeting('n_group', '0');
googletag.pubads().setTargeting('n_source', 'ie_iestaff');

googletag.pubads().disableInitialLoad();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

document.onreadystatechange = function(){
  function lazyloadAd(adUnit, adID){
    var adSlot = document.getElementById(adID);
    if (typeof(adSlot) != 'undefined' && adSlot != null){
      var adSlotRect = adSlot.getBoundingClientRect();
      var adSlotPosition = adSlotRect.top;
      var adSlotRefreshed = false;
      var adAlmostVisibleScrollValue = adSlotPosition - window.innerHeight - 200;
      var listener = function() {
        if (adAlmostVisibleScrollValue <= window.scrollY && !adSlotRefreshed){
          googletag.cmd.push(function() {
            googletag.pubads().refresh([adUnit]);
          });
          adSlotRefreshed = true;
          window.removeEventListener('scroll', listener);
        }
      }
      window.addEventListener('scroll', listener);
    }
  }
}
});
</script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/landmarkdigital-irishexaminer/loader.js',
  'tb_loader_script');
</script>
<script type="text/javascript">
            var _sf_async_config = _sf_async_config || {};
            _sf_async_config.uid = 39796;
            _sf_async_config.domain = 'irishexaminer.com';
            _sf_async_config.useCanonical = true;
            var _sf_startpt = (new Date()).getTime();
        </script>
<script src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript"> function isLoggedIn(s) { if (0 == s.errorCode) { var a = parseInt(s.data.bnbusiness); a ? a += 1 : a = 1; var t = s.data.bnbusiness_firstread; a ? a += 1 : a = 1; var n = (new Date).toISOString(); if (t) var r = { data: { bnbusiness: a.toString(), bnbusiness_lastread: n.toString() } }; else var r = { data: { bnbusiness: a.toString(), bnbusiness_lastread: n.toString(), bnbusiness_firstread: n.toString() } }; gigya.accounts.setAccountInfo(r) } } var logParams = { callback: isLoggedIn }; gigya.accounts.getAccountInfo(logParams); </script>

<title>

</title></head>
<body class="cbp-spmenu-push basic-template">




<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TJMCD4"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>    (function (w, d, s, l, i) {
        w[l] = w[l] || []; w[l].push({ 'gtm.start':
new Date().getTime(), event: 'gtm.js'
        }); var f = d.getElementsByTagName(s)[0],
j = d.createElement(s), dl = l != 'dataLayer' ? '&l=' + l : ''; j.async = true; j.src =
'//www.googletagmanager.com/gtm.js?id=' + i + dl; f.parentNode.insertBefore(j, f);
    })(window, document, 'script', 'dataLayer', 'GTM-TJMCD4');</script>

<div class="mob-overlay">
</div>
<div class="top-bar">
<div class="container">
<ul class="left">
<li><a href="/epaper/">ePaper</a></li>
<li><a href="/info/postaldeliveryenquiry/">Postal Delivery</a> </li>
<li><a href="http://photos.examiner.ie/" target="_blank">Photos</a> </li>
<li><a href="/competitions/">Competitions</a> </li>
<li><a href="/archive/">Newspaper Archive</a> </li>
<li><a href="/info/advertisingenquiry/">Advertise With Us</a> </li>
<li class="active"><a href="/shop/">Shop</a> </li>
<li><a href="/deathnotices/">Death Notices</a> </li>
</ul>
<ul class="right">
<li>Find a... </li>
<li><a href="/property/"><span class="icon-home"></span>Home</a> </li>
<li><a href="http://www.recruitireland.com" target="_blank"><span class="icon-case">
</span>Job</a> </li>
</ul>
</div>
</div>
<header>
<div class="container">
<a class="logo" href="/">IrishExaminer</a><button id="showLeftPush"><span class="icon-menu"></span></button>
<div class="banners"><div id='Marketing_Top' data-cb-ad-id='Marketing_Top' class='ad'><div id='div-gpt-ad-1346688247801-4' style='width:298px; height:73px;'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-4');googletag.pubads().refresh([n_ie_marketing_298x73 ]);});</script></div></div></div>
</div>
</header>
<div class="container">
<nav class="cbp-spmenu cbp-spmenu-vertical cbp-spmenu-left" id="cbp-spmenu-s1">
<span class="header">Menu
<button id="hideLeftPush">
<span class="icon-close"></span>
</button>
</span>
<ul>

<li class="main-menu"><span id="loginTextMobile"><a onclick="toDo()" class="loginClassMobile">Login</a></span></li>
<li class="main-menu"><span id="logoutButtonMobile"></span></li>
<li class="active main-menu"><a href="/">Home mobile</a> </li>
<li class="main-menu"><a href="/maintopics/">Hot Topics</a> </li>
<li class="current main-menu">
<span class="news"><a href="/ireland/">News</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/breakingnews/">- Breaking News</a></li>
<li><a href="/ireland/">- Today's Stories</a></li>
<li><a href="/specialreports/">- Special Reports</a></li>
<li><a href="/breakingnews/world/">- World</a></li>
<li><a href="/breakingnews/farming/">- Farming</a></li>
<li><a href="/weather/">- Weather</a></li>
<li><a href="/archives/">- Web Archive</a></li>
<li><a href="/archive/">- Newspaper Archive</a> </li>
</ul>
</li>
<li class="current main-menu1">
<span class="news"><a href="/sport/">Sport</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/breakingnews/sport/">- Breaking News</a></li>
<li><a href="/sport/gaa/">- GAA</a></li>
<li><a href="/sport/gaa/football/">- Football</a></li>
<li><a href="/sport/gaa/hurling/">- Hurling</a></li>

<li><a href="/sport/rugby/">- Rugby</a></li>
<li><a href="/sport/soccer/">- Soccer</a></li>
<li><a href="/sport/racing/">- Racing</a></li>
<li><a href="/sport/golf/">- Golf</a></li>
<li><a href="/sport/other-sports/">- Others</a></li>
<li><a href="/sport/columnists/">- Columns</a></li>
</ul>
</li>
<li class="current main-menu2">
<span class="news"><a href="/lifestyle/">Lifestyle</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/lifestyle/artsfilmtv/">- Culture</a></li>
<li><a href="/lifestyle/fashionandbeauty/">- Fashion/Beauty</a></li>
<li><a href="/lifestyle/features/">- Features</a></li>
<li><a href="/lifestyle/foodanddrink/">- Food/Drink</a></li> 
<li><a href="/lifestyle/healthandlife/">- Health/Life</a></li>
<li><a href="/lifestyle/outdoors/">- Outdoors/Garden</a></li>
<li><a href="/lifestyle/outdoors/damien-enright/">- Damien Enright</a></li>
<li><a href="/lifestyle/outdoors/donal-hickey/">- Donal Hickey</a></li>
<li><a href="/lifestyle/outdoors/richard-collins/">- Richard Collins</a></li>
<li><a href="/lifestyle/outdoors/dick-warner/">- Dick Warner</a></li>
<li><a href="/lifestyle/showbiz/">- Showbiz</a> </li>
<li><a href="/lifestyle/travel/">- Travel</a></li>
<li><a href="/lifestyle/homeandinteriors/">- Home</a></li>
</ul>
</li>
<li class="current main-menu3">
<span class="news"><a href="/viewpoints/">Viewpoints</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/viewpoints/columnists/">- Columns</a></li>
<li><a href="/viewpoints/analysis/">- Analysis</a></li>
<li><a href="/viewpoints/ourview/">- Our View</a></li>
<li><a href="/viewpoints/yourview/">- Your View</a></li>
<li><a href="/viewpoints/letters/sendletter">- Send your views</a></li>
</ul>
</li>
<li class="current main-menu4">
<span class="news"><a href="/video/">Video</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/video/news/">- Video News</a></li>
<li><a href="/video/sport/">- Video Sport</a></li>
<li><a href="/video/lifestyle/">- Video Lifestyle</a></li>
<li><a href="/video/viral/">- Video Viral</a></li>
<li><a href="/video/youmayhavemissed/">- Video You May Have Missed</a></li>
</ul>
</li>
<li class="current main-menu5">
<span class="news"><a href="/breakingnews/business/">Business</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/breakingnews/technow/">- Technology</a></li>
</ul>
</li>
<li class="current main-menu6">
<span class="news"><a href="/examviral/">ExamViral</a></span>

</li>
<li class="current main-menu7">
<span class="news"><a href="/technow/">TechNow</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="/technow/tech/">- Technology</a></li>
<li><a href="/technow/games/">- Gaming</a></li>
</ul>
</li>
<li class="current main-menu8">
<span class="news"><a href="/property/">Property</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="http://property.examiner.ie">- Property Search</a></li>
</ul>
</li>
<li class="main-menu"><a href="/breakingnews/entertainment/">Showbiz</a></li>
<li class="main-menu"><a href="/ford100/">Ford 100</a></li>
<li class="main-menu"><a href="/lifestyle/horoscopes/">Horoscopes</a></li>
<li class="main-menu"><a href="/deathnotices/">Death Notices</a></li>
<li class="current main-menu10">
<span class="news"><a href="/info/help/">Help</a><span class="arv"></span></span>
<ul class="submenu">
<li class="main-menu"><a href="/info/advertisingenquiry/">- Advertise With Us</a> </li>
<li class="main-menu"><a href="/getmobile/">- Apps</a></li>
<li class="main-menu"><a href="/competitions/">- Competitions</a> </li>
<li class="main-menu"><a href="/epaper/">- ePaper</a></li>
<li class="main-menu"><a href="http://photos.examiner.ie/" target="_blank">- Photos</a> </li>
<li class="main-menu"><a href="/info/postaldeliveryenquiry/">- Postal Delivery</a> </li>
<li class="main-menu"><a href="/shop/">- Shop</a> </li>
</ul>
</li>
<li class="current main-menu11">
<span class="news"><a href="#">Find a</a><span class="arv"></span></span>
<ul class="submenu">
<li><a href="http://property.examiner.ie/" target="_blank">- Home</a> </li>
<li><a href="https://www.recruitireland.com/" target="_blank">- Job</a> </li>
</ul>
</li>
<li class="current main-menu12">
<span class="news"><a href="#"></a></span>
<ul class="submenu"></ul>
</li>
<li class="current main-menu13">
<span class="news"><a href="#"></a></span>
<ul class="submenu"></ul>
</li>
</ul>
</nav>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
<script type="text/javascript">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</script>
<nav class="main">
<div class="container">
<ul>
<li><a href="/">News</a></li>
<li><a href="/sport/">Sport</a></li>
<li><a href="/breakingnews/business/">Business</a></li>
<li><a href="/viewpoints/">Views</a></li>
<li><a href="/lifestyle/">Life</a></li>
<li><a href="/examviral/">ExamViral</a></li>
<li><a href="/property/">Property</a></li>
<li><a href="/breakingnews/technow/">Tech</a></li>
<li><a href="/video/">Video</a></li>
<li><a href="/breakingnews/entertainment/">Showbiz</a></li>
<li><a href="/motors/">Motoring</a></li>
</ul>

<ul class="loginNav">
<li id="loginMenu"><span id="userLoginIcon"><img alt="" id="login-user-icon" src="/images/social/icon-user-you.png" /></span><span id="loginText"><a onclick="toDo()" class="loginClass">Login</a></span></li>
<li><span id="logoutButton"></span></li>
</ul>
<div class="search">
<form action="//www.irishexaminer.com/search/">
<input type="hidden" name="cx" value="004422957488353982429:4gb73lvknqy" />
<input type="hidden" name="cof" value="FORID:9" />
<input type="hidden" name="ie" value="UTF-8" />
<input type="text" name="q" placeholder="SEARCH SITE" /><button type="submit">go</button>
</form>
</div>
</div>
</nav>

<nav class="secondary">
<div class="container">
<ul id="secondary-nav">
<li class="selected">
<a href="/breakingnews/">Latest</a><span class="icon-subnav dropdown-trigger"></span>
<ul>
<li><a href="/breakingnews/ireland/">Ireland</a></li>
<li><a href="/breakingnews/world/">World</a></li>
<li><a href="/breakingnews/sport/">Sport</a></li>
<li><a href="/breakingnews/business/">Business</a></li>
<li><a href="/breakingnews/entertainment/">Showbiz</a></li>
<li><a href="/breakingnews/lotto/">Lotto</a></li>
</ul>
</li>
<li><a href="/ireland/">Ireland Today</a></li>
<li><a href="/breakingnews/business/">Business</a></li>
<li><a href="/breakingnews/farming/">Farming</a></li>
<li><a href="/breakingnews/world/">World</a></li>
<li><a href="/deathnotices/">Deaths</a></li>
<li>
<a href="/weather/">Weather</a><span class="icon-subnav dropdown-trigger"></span>
<ul>
<li><a href="/weather/">National Weather</a></li>
<li><a href="/weather/connacht/">Connacht</a></li>
<li><a href="/weather/leinster/">Leinster</a></li>
<li><a href="/weather/munster/">Munster</a></li>
<li><a href="/weather/ulster/">Ulster</a></li>
<li><a href="/weather/world/">World</a></li>
</ul>
</li>
<li>
<a href="#">More</a><span class="icon-subnav dropdown-trigger"></span>
<ul>
<li><a href="/archives/">Web Archive</a></li>
<li><a href="/horoscopes/" target="_blank">Horoscopes</a></li>
<li><a href="/specialreports/">Special Reports</a></li>
</ul>
</li>
</ul>

<ul id='secondary-nav'><li class='hottopics'><a href='/maintopics/'>HOT TOPICS:</a></li><li><a class='groupinnav' href='/ford100/'>Ford 100</a></li><li><a class='groupinnav' href='/maintopics/texas-shooting-4537.html'>Texas shooting</a></li><li><a class='groupinnav' href='/maintopics/paradise-papers-4536.html'>Paradise Papers</a></li><li><a class='groupinnav' href='/maintopics/catalonia-4526.html'>Catalonia</a></li><li><a class='groupinnav' href='/maintopics/cork-flood-plan-4449.html'>Cork Flood Plan</a></li><li><a class='groupinnav' href='/maintopics/8th-amendment-4379.html'>8th Amendment</a></li><li><a class='groupinnav' href='/maintopics/brexit-4106.html'>Brexit</a></li></ul>
</div></nav>




</div>
<div class="container stickyad">
<div class="leaderboard flash-950">
<div id='LeaderTop' data-cb-ad-id='Leader' class='ad'><div id='div-gpt-ad-1346688247801-0'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-0');googletag.pubads().refresh([n_ie_leader_728x90]);});</script></div></div>
</div>
</div>

<div class="breadcrumbs">
<div class="container">
<a href="/">Home</a><span>&raquo;</span><a href='/breakingnews/'>Breaking News</a><span>&raquo;</span><a href='/breakingnews/business/'>business</a>
</div>
</div>

<div class="container content">
<div class="col-wrapper">
<div class="col-left-story">
<h1>Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire</h1><div class='share-buttons clearfix'>
<div id='shareDiv'>
</div>
<script type="text/javascript">
function chkButton(btn) {
if (btn.shareItem.provider == 'comments') {
var comDiv = document.getElementById('commentsDiv');
comDiv.scrollIntoView(false); } }
var act = new gigya.socialize.UserAction();
act.setLinkBack("http://www.irishexaminer.com/breakingnews/business/sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire-814697.html");
act.setTitle("Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire");
var showShareBarUI_params_side = {
 containerID: 'shareDiv',
shareButtons: [
{provider: 'facebook', tooltip: 'Recommend this on Facebook', iconImgUp:'/images/social/facebook-gigya.png', iconOnly: true},
{provider: 'twitter', tooltip: 'Share on Twitter', iconImgUp:'/images/social/twitter-gigya.png', iconOnly: true},
{provider: 'googleplus', tooltip: 'Share on Google+',  iconImgUp:'/images/social/googleplus-gigya.png', iconOnly: true},
{provider: 'share', tooltip: 'More share options',  iconImgUp:'/images/social/more-gigya.png', iconOnly: true, enableCount:false} 
],
 onShareButtonClicked: chkButton, 
 userAction: act };
</script>
<script type="text/javascript">gigya.socialize.showShareBarUI(showShareBarUI_params_side);</script>
</div><div class="byline">Saturday, November 18, 2017 - 07:30 am</div><div class='generic-text'>
<div class="ctx_content"><story><p>Twenty-First Century Fox shares jumped in US trading and Sky shares rose in London after sources said both Comcast and Verizon Communications were also interested in buying parts of its studio and TV operations.</p><p>A week after reports of interest from Walt Disney in buying out much of Rupert Murdoch&rsquo;s US film and television empire, the sources hinted at the prospect of a battle between other media suitors for the assets.</p><p>Buyers have expressed interest in Fox&rsquo;s production studios, cable networks FX and National Geographic, and international assets such as the Star network in India and Sky, sources told Reuters. Fox shares have gained about 9% in value in the last six months.</p><p>Sky shares shot up by over 3% at one stage to the top of the FTSE. &ldquo;Comcast&rsquo;s interest in the 39% stake in Sky seems plausible,&rdquo; said Liberum analysts. &ldquo;Its NBC Universal has publicly stated its interest in expanding its non-US assets for a number of years and the UK is a key market for many of the US media groups,&rdquo; the analysts said. The US groups&rsquo; interest demonstrates Fox&rsquo;s stake in Sky is still seen as a valuable asset, Liberum added.</p><p><p><figure class='imgF'><img src="http://www.eveningecho.ie/portalsuite/image/d86e2d90-075c-4cf0-a811-12b5bfc54576/mainMediaSize=600x325_type=image_publish=true_x0=0_x1=100_y0=19.31_y1=91.27_format=1.7777777777777777_image.jpg"><figcaption class='imgFCap'>A week after reports of interest from Walt Disney in buying out&nbsp;much of Rupert Murdoch&rsquo;s US film and television empire, sources&nbsp;have hinted at the prospect of a battle between other media suitors&nbsp;for the assets. Picture: Evan Agostini/Invision/AP</figcaption></figure></center></p><p>&ldquo;Either Disney or Comcast would be a good fit, but its always about price and neither has to be a strategic buyer, only opportunistic,&rdquo; said JBL Advisors analyst Jeffrey Logsdon. Shares of other media companies which could be dragged into a round of consolidation of US film and TV production and distribution were largely unchanged. Comcast, the largest cable provider in the US, has steadily boosted its content ownership over the years and buying Fox&rsquo;s assets would give it an international distribution footprint and strengthen its position against Disney.</p><p>Traditional media companies have been struggling with subscriber declines as streaming service Netflix has gained traction with younger audiences that shun cable and satellite offerings.<script type='text/javascript' async src='//landmarkads.mainroll.com/p/inarticle/c/2454512.js?dart_n_story_id=ie_814697&dart_n_section=ie_business_bn'></script><p>Netflix and Verizon shares were marginally higher at one stage. Disney and Comcast shares both inched down. Fox and Disney are co-owners of Hulu, a streaming service that offers on-demand and live TV packages. Hulu is also partially owned by Comcast and Time Warner. Although acquisition of a movie studio and cable channels would be a departure for wireless carrier Verizon, its interest in Fox assets was likely piqued by rival AT&amp;T&rsquo;s bid for HBO and CNN owner Time Warner, which is awaiting regulatory approval.</p><p>&ldquo;(I am) sceptical of a Verizon deal, creative businesses are very tough to manage for an outsider,&rdquo; Mr Logsdon said.</p><p>Fox&rsquo;s other assets include Fox television network, Fox News Channel and Fox Entertainment Group.</p><p>Reuters</p><p><div class='pager top'><a class='previos' href='/breakingnews/business/revenue-declares-84m-haul-in-offshore-assets-814696.html?utm_source=link&amp;utm_medium=click&amp;utm_campaign=nextandprev'></a><a class='next' href='/breakingnews/business/cork-firms-confident-in-face-of-challenges-814698.html?utm_source=link&amp;utm_medium=click&amp;utm_campaign=nextandprev'></a><a id="mobileLeftButton" href='/breakingnews/business/revenue-declares-84m-haul-in-offshore-assets-814696.html?utm_source=link&amp;utm_medium=click&amp;utm_campaign=nextandprev'><img id="leftArrow" src="/images/mobile/halfcircleleft.png" /></a><a id="mobileRightButton" href='/breakingnews/business/cork-firms-confident-in-face-of-challenges-814698.html?utm_source=link&amp;utm_medium=click&amp;utm_campaign=nextandprev'><img id="rightArrow" src="/images/mobile/halfcircleright.png" /></a></div></p></p><script type='text/javascript'>
var ULTIMEDIA_mdtk = '02156613'; 
var ULTIMEDIA_zone= 2; 
var ULTIMEDIA_target = 'ultimedia_wrapper'; 
var ULTIMEDIA_async = false; 
</script>
<script type='text/javascript' src='http://www.ultimedia.com/js/common/smart.js'></script>
</br>
</story></div>

<div class='share-buttons bottom clearfix'><div class='share-buttons bottom clearfix'><iframe src="https://www.facebook.com/plugins/like.php?href=http%3A%2F%2Fwww.facebook.com%2FIrishExaminer&amp;layout=button_count&amp;show_faces=false&amp;width=90&amp;action=like&amp;font=verdana&amp;colorscheme=light" allowtransparency="true" style="border:medium none; overflow: hidden; width: 100px; height: 21px;" frameborder="0" scrolling="no"></iframe><iframe src="//platform.twitter.com/widgets/follow_button.html?screen_name=irishexaminer&show_count=false" style="width: 200px; height: 21px;" allowtransparency="true" frameborder="0" scrolling="no"></iframe></div></div><div id="shareSidebar">
<div id='sideShareDiv'>
</div>
</div>
<script type="text/javascript">
var act = new gigya.socialize.UserAction();
act.setLinkBack("http://www.irishexaminer.com/breakingnews/business/sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire-814697.html");
act.setTitle("Sky and Fox shares rise as rivals eye Rupert Murdoch’s empire");
var showShareBarUI_params = {
 containerID: 'sideShareDiv',
shareButtons: [
{provider: 'facebook', tooltip: 'Recommend this on Facebook', iconImgUp:'/images/social/sidebar/facebook-gigya-side.png', iconImgOver: '/images/social/sidebar/facebook-gigya-side-hover.png', iconOnly: true},
{provider: 'twitter', tooltip: 'Share on Twitter', iconImgUp:'/images/social/sidebar/twitter-gigya-side.png', iconImgOver: '/images/social/sidebar/twitter-gigya-side-hover.png',  iconOnly: true},
{provider: 'googleplus', tooltip: 'Share on Google+',  iconImgUp:'/images/social/sidebar/googleplus-gigya-side.png', iconImgOver: '/images/social/sidebar/googleplus-gigya-side-hover.png',  iconOnly: true},
{provider: 'share', tooltip: 'More share options',  iconImgUp:'/images/social/sidebar/more-gigya-side.png', iconImgOver: '/images/social/sidebar/more-gigya-side-hover.png',  iconOnly: true}
],
 layout:  'vertical',
 showCounts:  'none',
 userAction: act };
</script>
<script type="text/javascript">gigya.socialize.showShareBarUI(showShareBarUI_params);</script>
</div><div class='emailupdates'><div class='story-page-footer'><h2 class='email-title'>News Daily Headlines</h2><p class='email-subtext'>Receive our lunchtime briefing straight to your inbox</p><div id='mc_embed_signup' class='subscribe-box-articles'><form action='https://landmarkdigital.us6.list-manage.com/subscribe/post?u=caa589fc19&amp;id=c96f7404b9' method='post' id='mc-embedded-subscribe-form' name='mc-embedded-subscribe-form' class='validate' target='_blank' novalidate=''><input type='email' name='EMAIL' class='email-field' id='mce-EMAIL' placeholder='Your email address...'><input type='submit' value='Sign Me Up' name='subscribe' id='mc-embedded-subscribe' class='go-button'></form></div></div></div><div class='more-in-this-section'></div><div class='story-page-wrapper'><div class='story-page-footer'><div class='story-page-footer-header'><p class='story-page-footer-title'>More in this Section</p></div><p class='story-page-element-content'><a style='color:black' title="Businesses in Cork are unanimously confident about the future despite external threats such as Brexit, according to a survey, with more than three-quarters of firms planning to hire in the next year." href='/breakingnews/business/cork-firms-confident-in-face-of-challenges-814698.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/c/CorkCityRiverLeeAerialView.jpg?width=300&s=ie-814698' />Cork firms confident in face of challenges</a></p><p class='story-page-element-content'><a style='color:black' title="The Revenue said it received information on &euro;84m in offshore assets before a late spring deadline, and confirmed it will investigate the latest revelations made in the so-called Paradise Papers." href='/breakingnews/business/revenue-declares-84m-haul-in-offshore-assets-814696.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/r/RevenueImageNOFEE.jpg?width=300&s=ie-814696' />Revenue declares €84m haul in offshore assets</a></p><p class='story-page-element-content'><a style='color:black' title="Japanese fair trade regulators raided last month the offices of Airbnb over suspected violations of antitrust laws, the home rental site has revealed, denying any wrongdoing." href='/breakingnews/business/airbnb-documents-seized-in-japanese-raid-814695.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/a/Airbnb.jpg?width=300&s=ie-814695' />Airbnb documents seized in Japanese raid</a></p><p class='story-page-element-content'><a style='color:black' title="Pre-tax profits at department store retailer Michael Guiney &mdash; better known as Guineys &mdash; has climbed to &euro;2.45m." href='/breakingnews/business/guineys-builds-its-profits-as-sales-rise-10-to-238m-814694.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/m/MichaelGuineyShop.jpg?width=300&s=ie-814694' />Guineys builds its profits as sales rise 10% to €23.8m</a></p></div></div><br clear='all'>
<div id="taboola-below-article-thumbnails"></div>
<script type='text/javascript'>window._taboola = window._taboola || [];  _taboola.push({  mode: 'thumbnails-a', container: 'taboola-below-article-thumbnails', placement: 'Below Article Thumbnails', target_type:'mix' }); </script>
<div class="more-in-this-section"></div><div class='story-page-wrapper'><div class='story-page-footer'><div class='story-page-footer-header'><p class='story-page-footer-title'>Today's Stories</p></div><p class='story-page-element-content'><a style='color:black' title="Taoiseach Leo Varadkar wants to legislate to ban zero-hour contracts and to promote employment conditions that deliver well-paid jobs with pensions, writes Paul Mills." href='/ireland/is-this-the-end-for-zero-hour-contracts-462914.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/j/JobsSignGeneric.jpg?width=300&s=ie-462914' />Is this the end for zero-hour contracts?</a></p><p class='story-page-element-content'><a style='color:black' title="The European Union needs a quick agreement on proposed rules for lawyers, bankers and other advisers that help devise ways to aggressively cut tax bills, the European tax commissioner Pierre Moscovici has said, writesFrancesco Guarascio." href='/ireland/the-european-union-seeks-tax-rule-action-462842.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/j/JobsSignGeneric.jpg?width=300&s=ie-462914' />The European Union seeks tax rule action</a></p><p class='story-page-element-content'><a style='color:black' title="Analysts are more optimistic than the UK government that an agreement will be reached with the EU next month to move Brexit talks on to trade, even as Theresa May&rsquo;s political troubles continue to weigh on the country&rsquo;s beleaguered currency, writes Charlotte Ryan." href='/ireland/despite-the-ticking-clock-some-optimism-over-sterling-462841.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/p/PoundCoinsSterlingPA.jpg?width=300&s=ie-462841' />Despite the ticking clock, some optimism over sterling</a></p><p class='story-page-element-content'><a style='color:black' title="Tesco shares rose by over 7% as it won provisional approval for its &pound;3.7bn (&euro;4.1bn) takeover of wholesaler Booker from the UK competition regulator, moving the UK&rsquo;s biggest retailer closer to securing a new avenue of growth, writes James Davey." href='/ireland/tesco-shares-climb-on-green-light-for-booker-deal-462840.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/t/tescoLogo.jpg?width=300&s=ie-462840' />Tesco shares climb on green light for Booker deal</a></p></div></div><div class="more-in-this-section"></div><div class='story-page-wrapper'><div class='story-page-footer'><div class='story-page-footer-header'><p class='story-page-footer-title'>Lifestyle</p></div><p class='story-page-element-content'><a style='color:black' title="Tarquin Blake&rsquo;s history of Irish castles charts beautiful buildings and a grant-aid culture that goes back six centuries, writes Tommy Barker" href='/lifestyle/artsfilmtv/books/a-towering-achievement-exploring-irish-castles-and-beautiful-buildings-463036.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/e/ExploringIrelandsCastles171117.jpg?width=300&s=ie-463036' />A towering achievement: Exploring Irish castles and beautiful buildings</a></p><p class='story-page-element-content'><a style='color:black' title="Peter Dowdall on two books that are well worth their place on any gardener&rsquo;s bookshelf this season" href='/lifestyle/outdoors/books-that-belong-on-the-gardeners-bookshelf-463035.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/z/ZoeDevlinPeterDowdallColumn171117.jpg?width=300&s=ie-463035' />Books that belong on the gardener's bookshelf</a></p><p class='story-page-element-content'><a style='color:black' title="Kya delongchamps wonders if a meticulously-mannered 64-year-old Irish entrepreneur really could have have anything new to say in the housekeeping/sanity balance of life? It appears &lsquo;yes&rsquo; is the answer." href='/lifestyle/homeandinteriors/the-domestic-flash-of-francis-brennan-463033.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/f/FrancisBrennanBookOfHouseholdManagement171117.jpg?width=300&s=ie-463033' />The domestic flash of Francis Brennan</a></p><p class='story-page-element-content'><a style='color:black' title="John Wilson, drummer with the seminal Irish band, is hitting the road again with some of the magic music hemade withRory Gallagher, writesEd Power" href='/lifestyle/artsfilmtv/john-wilson-touring-with-music-made-with-rory-gallagher-in-taste-462970.html'><img class='story-page-footer-image' src='/remote/media.central.ie/media/images/t/TasteBand.jpg?width=300&s=ie-462970' />John Wilson touring with music made with Rory Gallagher in Taste</a></p></div></div><div class='more-from'><p>More From The Irish Examiner</p><ul class='double-image'><li><a href='/frontpages/'><img src='/images/shop/front-page-prints-659x355.jpg' /></a></li><li><a href='http://photos.examiner.ie/'><img src='/images/shop/photosalesnew-659x355.jpg' /></a></li><li><a href='http://www.irishexaminer.com/epaper/'> <img src='/images/shop/epaper2-659x355.jpg' /></a></li><li><a href='/archive/'> <img src='/images/shop/659x355_digitalarchive.jpg' /></a></li></ul></div></div>
<div class="col-middle">
</div>
<div class="col-right">


<div class="sidebar-unit stickyad2" id="top-mpu-ad">
<center><div id='MPUTop' data-cb-ad-id='MPU_Top' class='ad'><div id='div-gpt-ad-1346688247801-2'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-2');googletag.pubads().refresh([n_ie_mpu_start_300x250]);});</script></div></div></center>
</div>

<div id='div-gpt-ad-1479983964240-0'>
<script type='text/javascript'>
                        googletag.cmd.push(function () { 
                            googletag.display('div-gpt-ad-1479983964240-0');
                            googletag.pubads().refresh([n_ie_marketing_mpu]); 
                        });
                    </script>
</div>

<div class="sidebar-unit">
</div>
<div class="sidebar-unit">
<a href='/examviral'><img src='/images/exam_viral_300x50.jpg' /></a><div class='sidebar-unit'><div class='most-read'><div class='text-body'><div class='tab-content'><div class='tab-pane active' id='mostread'><ul data-vr-zone='most-read-stories'><li data-vr-contentbox=''><a href='/examviral/a-list-photographer-rankin-selects-his-favourite-street-snaps-from-a-beautiful-new-book-814709.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2017/11/17113840/5326a50f-5e04-40a9-b512-780aeba19680.jpg?crop=0,94,1500,938&ext=.jpg&width=300&s=ie-814709" width="300" height="160" /></a><a href='/examviral/a-list-photographer-rankin-selects-his-favourite-street-snaps-from-a-beautiful-new-book-814709.html'>A-list photographer Rankin selects his favourite street snaps from a beautiful new book</a><li data-vr-contentbox=''><a href='/examviral/uk-arts-minister-hopes-buyer-can-help-keep-salvador-dalis-mae-west-lips-sofa-in-the-country-814707.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2017/11/17132618/14fc56a4-985a-4c91-a68a-5e3a0bcefd82.jpg?crop=0,563,1706,1523&ext=.jpg&width=300&s=ie-814707" width="300" height="160" /></a><a href='/examviral/uk-arts-minister-hopes-buyer-can-help-keep-salvador-dalis-mae-west-lips-sofa-in-the-country-814707.html'>UK Arts Minister hopes buyer can help keep Salvador Dali’s Mae West Lips sofa in the country</a><li data-vr-contentbox=''><a href='/examviral/a-black-labrador-dropped-the-puck-at-an-nhl-game-and-everyone-agreed-he-did-a-great-job-814701.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2017/11/17162821/3b007e44-30d4-4089-854c-6e776b324522.jpg?crop=0,0,1920,1080&ext=.jpg&width=300&s=ie-814701" width="300" height="160" /></a><a href='/examviral/a-black-labrador-dropped-the-puck-at-an-nhl-game-and-everyone-agreed-he-did-a-great-job-814701.html'>A black labrador dropped the puck at an NHL game and everyone agreed he did a great job</a><li data-vr-contentbox=''><a href='/examviral/two-new-snow-gritters-secured-the-best-names-after-a-twitter-world-cup-contest-full-of-puns-814687.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2017/11/17152248/1fa07989-6a42-4476-99ed-e7ad9abe834f.jpg?crop=0,0,1902,1070&ext=.jpg&width=300&s=ie-814687" width="300" height="160" /></a><a href='/examviral/two-new-snow-gritters-secured-the-best-names-after-a-twitter-world-cup-contest-full-of-puns-814687.html'>Two new snow gritters secured the best names after a Twitter World Cup contest full of puns</a><li data-vr-contentbox=''><a href='/examviral/these-brilliant-animations-give-hilarious-new-meaning-to-classic-movie-lines-814665.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2017/11/17151802/027c85f0-8c65-4878-a550-025098a2ff65.jpg?crop=0,0,1920,1080&ext=.jpg&width=300&s=ie-814665" width="300" height="160" /></a><a href='/examviral/these-brilliant-animations-give-hilarious-new-meaning-to-classic-movie-lines-814665.html'>These brilliant animations give hilarious new meaning to classic movie lines</a><li data-vr-contentbox=''><a href='/examviral/watch-the-incredible-moment-a-meteor-strike-lights-up-the-night-sky-in-lapland-814660.html'><img itemprop="image" src="/remote/content.assets.pressassociation.io/2017/11/17134120/081a128f-d26f-49c7-92f2-32109546d4e9.jpg?crop=0,120,1920,1200&ext=.jpg&width=300&s=ie-814660" width="300" height="160" /></a><a href='/examviral/watch-the-incredible-moment-a-meteor-strike-lights-up-the-night-sky-in-lapland-814660.html'>Watch the incredible moment a meteor strike lights up the night sky in Lapland</a></ul></div></div></div></div></div><form name="aspnetForm" method="post" action="./sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire-814697.html?c=business&amp;jp=814697&amp;h=sky-and-fox-shares-rise-as-rivals-eye-rupert-murdochs-empire&amp;t=html" id="aspnetForm">
<input type="hidden" name="__VIEWSTATE" id="__VIEWSTATE" value="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" />

<input type="hidden" name="__VIEWSTATEGENERATOR" id="__VIEWSTATEGENERATOR" value="72ED1BD1" />
<input type="hidden" name="__EVENTVALIDATION" id="__EVENTVALIDATION" value="/wEdAASUA169vPGpJepee85OH/exfgivf6waS+P2vDk5sTHDJ1vWujcrRo5LJaXsi8T4nk+SKGRakVEtPAXcscbjmEe2e4PZJLuZc/AxcLxe4JwftWkxx7w=" />
 <br />
    <div class="ri_container">
		<div class="ri_background">
			<div class="ri_logo">
				<img class="ri" src="http://media.irishexaminer.com/marketing/recruitirelandlogo.png" />
			</div>
			<div class="ri_title">
				<h2>Start the search</h2>
			</div>
			<div class="ri_divider">

			</div>
			<div class="ri_sub_title">
				<p>for your new job</p>
			</div>
			<div class="controls">
				<div class="input-box">
                        <input name="ctl00$fpTextbox" type="text" id="ctl00_fpTextbox" placeholder="e.g. engineer" />
                   	</div>
				<div class="input-box">
					   <select name="ctl00$fbSelect" id="ctl00_fbSelect">
	<option selected="selected" value="">All Regions</option>
	<option value="Dublin County">Dublin</option>
	<option value="Cork">Cork</option>
	<option value="Limerick">Limerick</option>
	<option value="Galway">Galway</option>
	<option value="---------------------">---------------------</option>
	<option value="Dublin County">Dublin</option>
	<option value="Dublin North">Dublin North</option>
	<option value="Dublin South">Dublin South</option>
	<option value="Dublin West">Dublin West</option>
	<option value="Dublin City Centre">Dublin City Centre</option>
	<option value="Antrim">Antrim</option>
	<option value="Armagh">Armagh</option>
	<option value="Carlow">Carlow</option>
	<option value="Cavan">Cavan</option>
	<option value="Clare">Clare</option>
	<option value="Cork">Cork</option>
	<option value="Derry">Derry</option>
	<option value="Donegal">Donegal</option>
	<option value="Down">Down</option>
	<option value="Fermanagh">Fermanagh</option>
	<option value="Galway">Galway</option>
	<option value="Kerry">Kerry</option>
	<option value="Kildare">Kildare</option>
	<option value="Kilkenny">Kilkenny</option>
	<option value="Laois">Laois</option>
	<option value="Leitrim">Leitrim</option>
	<option value="Limerick">Limerick</option>
	<option value="Longford">Longford</option>
	<option value="Louth">Louth</option>
	<option value="Mayo">Mayo</option>
	<option value="Meath">Meath</option>
	<option value="Monaghan">Monaghan</option>
	<option value="Offaly">Offaly</option>
	<option value="Roscommon">Roscommon</option>
	<option value="Sligo">Sligo</option>
	<option value="Tipperary">Tipperary</option>
	<option value="Tyrone">Tyrone</option>
	<option value="Waterford">Waterford</option>
	<option value="Westmeath">Westmeath</option>
	<option value="Wexford">Wexford</option>
	<option value="Wicklow">Wicklow</option>
	<option value="---------------------">---------------------</option>
	<option value="Rest of Leinster">Rest of Leinster</option>
	<option value="Munster">Munster</option>
	<option value="Connaught/Ulster">Connaught/Ulster</option>
	<option value="Northern Ireland">Northern Ireland</option>
	<option value="Nationwide">Nationwide</option>
	<option value="---------------------">---------------------</option>
	<option value="UK">UK</option>
	<option value="Europe">Europe</option>
	<option value="Worldwide">Worldwide</option>
	<option value="Australia">Australia</option>
	<option value="United Arab Emirates">United Arab Emirates</option>
	<option value="New Zealand">New Zealand</option>
	<option value="Canada">Canada</option>
	<option value="USA">USA</option>
	<option value="North Africa">North Africa</option>
	<option value="South Africa">South Africa</option>
	<option value="Middle East">Middle East</option>
</select>
					<div class="triangle"></div>
				</div>
				<a id="ctl00_sBTN" class="icon-search test" title="GO" href="javascript:__doPostBack(&#39;ctl00$sBTN&#39;,&#39;&#39;)">GO</a>
			</div>

		</div>
	</div>
               </form>



                </div>


                
                
                    <!--Lotto -->
                    <div class="sidebar-unit">




                        <div class='lottos-right-side clearfix'>
<h2 class='lotto-bold-header-right-side'>Lotto Results</h2><h2>Wednesday, November 15, 2017</h2>
<ul class='lotto-results-widget-right-side clearfix'><ul class='lotto-numbers-widget-right-side'><li><span class='lotto-number-widget-right-side orange'>4</span></li>
<li><span class='lotto-number-widget-right-side blue'>7</span></li>
<li><span class='lotto-number-widget-right-side green'>17</span></li>
<li><span class='lotto-number-widget-right-side blue'>19</span></li>
<li><span class='lotto-number-widget-right-side blue'>27</span></li>
<li><span class='lotto-number-widget-right-side red'>34</span></li>
<li class='last-right-side'><span class='lotto-number-widget-right-side green'>9<span aria-hidden='true' class='icon-star-right-side'></span></span></li>
</ul></ul>
<h3><a title='Full Lotto draw results' href='/lotto/' class='more-results-right-side'>Full Lotto draw results &raquo;</a></h3>
</div>

                    </div>
                
                    <div class="sidebar-unit">
                        <div class="s-block follow-ie">
<h2>
      Follow the Irish Examiner
    </h2>
    <p>

    
      <!--<a href="http://twitter.com/irishexaminer" title="Twitter"><span class="icon-twitter"></span></a>
      <a href="http://www.facebook.com/irishexaminer" title="Facebook"><span class="icon-facebook"></span></a>
      <a href="https://plus.google.com/u/0/b/111234426392903310445/"><span class="icon-googleplus"></span></a>
      <a href="http://www.youtube.com/irishexaminer" title="Youtube"><span class="icon-youtube"></span></a>
      <a href="http://storify.com/IrishExaminer" title="Storify"><span class="icon-storyfy"></span></a>
      <a href="/competitions/sign-up-to-our-newsletter-11.html" title="Newsletter"><span class="icon-mail"></span></a>-->
        <a title="Twitter" href="http://twitter.com/irishexaminer"><span class="icon-twitter"></span></a>
        <a title="Facebook" href="http://www.facebook.com/irishexaminer"><span class="icon-facebook"></span></a>
        <a href="https://www.instagram.com/irish_examiner/" target="_blank"><span class="icon-instagram"></span></a>
        <a title="Youtube" href="http://www.youtube.com/irishexaminer"><span class="icon-youtube"></span></a>
        <a href="http://www.irishexaminer.com/info/whatsapp/" target="_blank" title="Whatsapp"><span class="icon-whatsapp" target="_blank"></span></a>
        <a title="Newsletter" href="/competitions/sign-up-to-our-newsletter-11.html"><span class="icon-mail"></span></a>
        <a title="Snapchat" href="https://www.snapchat.com/add/irishexaminer" target="_blank"><span class="icon-Snapchat"></span></a>




  </p>
  </div>

                    </div>
                

    <!--most read -->
<div class="sidebar-unit">

    <div class="most-read">
        <ul class="tab-header">
            <li class="active"><a data-toggle="tab" href="#mostread">Most Read</a> </li>
            <li><a data-toggle="tab" href="#topstories">Top Stories</a> </li>
            
        </ul>
        <div class="text-body">
            <div class="tab-content">
                <div class="tab-pane active" id="mostread"> <ul data-vr-zone="most-read-stories"><li data-vr-contentbox=""><a href='/breakingnews/ireland/ikea-launches-online-store-in-ireland-814449.html'><img itemprop="image" src="/remote/media.central.ie/media/images/i/Ikea.jpg?width=300&s=ie-814449" width="120" height="64" /></a><a href='/breakingnews/ireland/ikea-launches-online-store-in-ireland-814449.html'>IKEA launches online store in Ireland</a><br/></li><li data-vr-contentbox=""><a href='/ireland/former-cit-president-signed-off-on-his-own-retirement-function-463018.html'><img itemprop="image" src="/remote/media.central.ie/media/images/b/BrendanMurphyCITPresident.jpg?width=300&s=ie-463018" width="120" height="64" /></a><a title='Cork Institute of Technology is being asked for a full explanation of how its ex-president Brendan Murphy personally signed off on more than half the &euro;13,000 costs of two functions to mark his own retirement.' href='/ireland/former-cit-president-signed-off-on-his-own-retirement-function-463018.html'>Former CIT president signed off on his own retirement function</a></li><li data-vr-contentbox=""><a href='/breakingnews/business/data-law-awareness-scramble-for-irish-firms-814550.html'><img itemprop="image" src="/remote/media.central.ie/media/images/m/ManAtComputersData.jpg?width=300&s=ie-814550" width="120" height="64" /></a><a href='/breakingnews/business/data-law-awareness-scramble-for-irish-firms-814550.html'>Data law awareness scramble for Irish firms</a><br/></li><li data-vr-contentbox=""><a href='/ireland/online-abuse-by-fine-gael-member-is-unacceptable-463017.html'><img itemprop="image" src="/remote/media.central.ie/media/images/b/BarryWalsh2008.jpg?width=300&s=ie-463017" width="120" height="64" /></a><a title='Taoiseach Leo Varadkar has declared that &ldquo;nasty&rdquo; slurs targetting women online by a senior Fine Gael figure are &ldquo;not acceptable&rdquo; and debate should be conducted in a responsible way.' href='/ireland/online-abuse-by-fine-gael-member-is-unacceptable-463017.html'>Online abuse by Fine Gael member is ‘unacceptable’</a></li><li data-vr-contentbox=""><a href='/breakingnews/ireland/molly-martens-ex-fiance-says-he-dodged-a-bullet-814596.html'><img itemprop="image" src="/remote/media.central.ie/media/images/m/mollyMartensLedAway.jpg?width=300&s=ie-814596" width="120" height="64" /></a><a href='/breakingnews/ireland/molly-martens-ex-fiance-says-he-dodged-a-bullet-814596.html'>Molly Martens ex-fiancé says he &rsquo;dodged a bullet&rsquo;</a><br/></li><li data-vr-contentbox=""><a href='/ireland/probe-into-claim-sexual-harassment-within-prison-service-was-covered-up-463019.html'><img itemprop="image" src="/remote/media.central.ie/media/images/p/PrisonOfficer280915.jpg?width=300&s=ie-463019" width="120" height="64" /></a><a title='An investigation has been launched following allegations that a serious case of sexual harassment within the Prison Service was covered up.' href='/ireland/probe-into-claim-sexual-harassment-within-prison-service-was-covered-up-463019.html'>Probe into claim sexual harassment within Prison Service was covered up</a></li><li data-vr-contentbox=""><a href='/breakingnews/world/heroic-teachers-actions-see-three-year-old-girl-emerge-as-sole-survivor-in-russia-plane-crash-reports-814599.html'><img itemprop="image" src="/remote/media.central.ie/media/images/r/russiaplanecrashnov17.jpg?width=300&s=ie-814599" width="120" height="64" /></a><a href='/breakingnews/world/heroic-teachers-actions-see-three-year-old-girl-emerge-as-sole-survivor-in-russia-plane-crash-reports-814599.html'>Heroic teacher's actions see three-year-old-girl emerge as sole survivor in  Russia plane crash, reports</a><br/></li><li data-vr-contentbox=""><a href='/ireland/10-year-old-girls-note-detailed-alleged-sexual-assault-463003.html'><img itemprop="image" src="/remote/media.central.ie/media/images/c/CorkCircuitCourthouse.jpg?width=300&s=ie-463003" width="120" height="64" /></a><a title='A 10-year-old girl with writing and speech difficulties handed her mother a note at bedtime in which she suggested she had been the victim of a sexual assault, it was claimed by her mother.' href='/ireland/10-year-old-girls-note-detailed-alleged-sexual-assault-463003.html'>10-year-old girl’s note detailed alleged sexual assault</a></li><li data-vr-contentbox=""><a href='/breakingnews/ireland/latest-governments-clash-over-border-issue-taoiseach-suggests-brexit-not-thought-through-814567.html'><img itemprop="image" src="/remote/media.central.ie/media/images/v/VaradkarSwedenNov2017.jpg?width=300&s=ie-814567" width="120" height="64" /></a><a href='/breakingnews/ireland/latest-governments-clash-over-border-issue-taoiseach-suggests-brexit-not-thought-through-814567.html'>Latest: Government's  clash over border issue; Taoiseach suggests Brexit not thought through  </a><br/></li><li data-vr-contentbox=""><a href='/lifestyle/features/ask-audrey-come-here-do-posh-girls-fake-orgasms-462960.html'><img itemprop="image" src="/remote/media.central.ie/media/images/a/AskAudrey.jpg?width=300&s=ie-462960" width="120" height="64" /></a><a title='Ask Audrey has been sorting out Cork people for ages' href='/lifestyle/features/ask-audrey-come-here-do-posh-girls-fake-orgasms-462960.html'>Ask Audrey: 'Come here, do posh girls fake orgasms?'</a></li></ul></div>
                <div class="tab-pane" id="topstories"><ul data-vr-zone="top-stories"><li data-vr-contentbox="" class="ts-headline"><b>NEWS</b></li><li data-vr-contentbox=""><a href='/ireland/probe-into-claim-sexual-harassment-within-prison-service-was-covered-up-463019.html'><img itemprop="image" src="/remote/media.central.ie/media/images/p/PrisonOfficer280915.jpg?width=300&s=ie-463019" width="120" height="64" /></a><a title='An investigation has been launched following allegations that a serious case of sexual harassment within the Prison Service was covered up.' href='/ireland/probe-into-claim-sexual-harassment-within-prison-service-was-covered-up-463019.html'>Probe into claim sexual harassment within Prison Service was covered up</a></li><li data-vr-contentbox=""><a href='/ireland/selfish-drivers-oblivious-to-huge-devastation-they-could-cause-says-bereaved-cork-woman-462971.html'><img itemprop="image" src="/remote/media.central.ie/media/images/r/RoadSafetyAuthorityWorldDayofRememberanceLaunchNov17.jpg?width=300&s=ie-462971" width="120" height="64" /></a><a title='Elber Twomey&rsquo;s pain was etched on her face as she recalled the car crash that wiped out her family five years ago.' href='/ireland/selfish-drivers-oblivious-to-huge-devastation-they-could-cause-says-bereaved-cork-woman-462971.html'>‘Selfish drivers oblivious to huge devastation they could cause’, says bereaved Cork woman</a></li><li data-vr-contentbox="" class="ts-headline"><b>BUSINESS</b></li><li data-vr-contentbox=""><a href='/lifestyle/healthandlife/body-beautiful-amanda-byram-on-giving-up-fad-diets-462940.html'><img itemprop="image" src="/remote/media.central.ie/media/images/a/AmandaByramBodyBeautifulFeature161117.jpg?width=300&s=ie-462940" width="120" height="64" /></a><a title='Amanda Byram, model, TV presenter, and businesswoman, had always exercised but it wasn&rsquo;t until her 30s that she kicked the fad diets, writes Deirdre Reynolds' href='/lifestyle/healthandlife/body-beautiful-amanda-byram-on-giving-up-fad-diets-462940.html'>Body beautiful: Amanda Byram on giving up fad diets</a></li><li data-vr-contentbox="" class="ts-headline"><b>SPORT</b></li><li data-vr-contentbox=""><a href='/sport/columnists/liam-mackey/dont-write-off-martin-oneill-after-one-freak-occurrence-463082.html'><img itemprop="image" src="/remote/media.central.ie/media/images/m/MartinONeilldejected14Nov2017.jpg?width=300&s=ie-463082" width="120" height="64" /></a><a title='I can only bow down to the prophetic powers of those who say they saw Tuesday night&rsquo;s Aviva apocalypse coming, writesLiam Mackey.' href='/sport/columnists/liam-mackey/dont-write-off-martin-oneill-after-one-freak-occurrence-463082.html'>Don’t write off Martin O’Neill after one freak occurrence</a></li><li data-vr-contentbox=""><a href='/sport/columnists/ruby-walsh/faugheen-showing-speed-and-enthusiasm-on-gallops-463076.html'><img itemprop="image" src="/remote/media.central.ie/media/images/f/FaugheenWillieMullinsRubyWalshCheltenham2014PA.jpg?width=300&s=ie-463076" width="120" height="64" /></a><a title='After a week off I&rsquo;m really looking forward to getting back racing, and the return of Faugheen is a great motivation, writesRuby Walsh.' href='/sport/columnists/ruby-walsh/faugheen-showing-speed-and-enthusiasm-on-gallops-463076.html'>Faugheen showing speed and enthusiasm on gallops</a></li><li data-vr-contentbox="" class="ts-headline"><b>LIFESTYLE</b></li><li data-vr-contentbox=""><a href='/lifestyle/foodanddrink/derval-orourke-quick-and-easy-food-to-go-with-hard-hitting-exercises-462954.html'><img itemprop="image" src="/remote/media.central.ie/media/images/d/DervalORourkeFood161117.jpg?width=300&s=ie-462954" width="120" height="64" /></a><a title='This week I&rsquo;m sharing one of my favourite home workouts.' href='/lifestyle/foodanddrink/derval-orourke-quick-and-easy-food-to-go-with-hard-hitting-exercises-462954.html'>Derval O'Rourke: Quick and easy food to go with hard hitting exercises</a></li><li data-vr-contentbox=""><a href='/lifestyle/foodanddrink/restaurant-review-clanbrassil-house--dublin-462957.html'><img itemprop="image" src="/remote/media.central.ie/media/images/c/ClanbrassilHouseReview161117a.jpg?width=300&s=ie-462957" width="120" height="64" /></a><a title='&ldquo;Yeah, well, that&rsquo;s just like your opinion, man,&rdquo; drawled The Dude (as played by Jeff Bridges) in The Big Lebowski &ndash; the classic Coen Brothers film from 1998.' href='/lifestyle/foodanddrink/restaurant-review-clanbrassil-house--dublin-462957.html'>Restaurant review: Clanbrassil House - Dublin</a></li></ul></div>
            
            </div>
        </div>
    </div>

</div>




                    <div class="sidebar-unit mpu" id="bot-mpu-ad">
                        <!-- MPU end goes in right col on non-mobile version -->
                        
                            <center>
                                <!-- IE_ie_business_bn_MPU_End_300x250 --><div id='MPUEnd' data-cb-ad-id='MPU_End' class='ad'><div id='div-gpt-ad-1346688247801-1'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-1');googletag.pubads().refresh([n_ie_mpu_end_300x250]);});</script></div></div></center>
                        
                    </div>

                    
                

                <!-- end of rightColumnToHide --->
            



        </div>
    </div>
    </div>
    
    
        <footer><div class="container">
    <div class="foot-nav">
        <div class="foot-logos">
            <a href="http://www.nni.ie">
                <img src="/assets/images/layout/f-logo1.png" /></a><a href="http://www.presscouncil.ie"><img
                    src="/assets/images/layout/f-logo2.png" /></a>
        </div>
    </div>
    <div class="foot-nav">
        <span>News</span>
        <ul>
            <li><a href="/breakingnews/">Breaking News</a></li>
            <li><a href="/ireland/">Today&acute;s Paper</a></li>
            <li><a href="/breakingnews/world/">World</a></li>
            <li><a href="/business/">Business</a></li>
            <li><a href="/breakingnews/farming/">Farming</a></li>
            <li><a href="/breakingnews/technow/">Technology</a></li>
            <li><a href="/weather/">Weather</a></li>
            <li><a href="/deathnotices/">Death Notices</a></li>
            <li><a href="/archives/">Archives</a></li>
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/sport/">Sport</a></span>
        <ul>
            <li><a href="/sport/soccer/">Soccer</a></li>
            <li><a href="/sport/podcast/">Podcast</a></li>
            <li><a href="/sport/columnists/">Columnists</a></li>
            <li><a href="/sport/gaa/">GAA</a></li>
            <li><a href="/sport/rugby/">Rugby</a></li>
            <li><a href="/sport/golf/">Golf</a></li>
            <li><a href="/sport/racing/">Racing</a></li>
            <li><a href="/sport/other-sports/">Other Sport</a></li>
            <li><a href="/sport/results/">Results</a></li>
            <!--<li><a href="/rwc15/">RWC 2015</a></li>-->
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/viewpoints/">Viewpoints</a></span>
        <ul>
            <li><a href="/viewpoints/ourview/">Our view (editorial)</a></li>
            <li><a href="/viewpoints/yourview/">Your view (letters)</a></li>
            <li><a href="/viewpoints/letters/sendletter">Send letter to editor's page</a></li>
            <li><a href="/columnists/">Columnists</a></li>
            <li><a href="/lifestyle/artsfilmtv/books/">Books</a></li>
       </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/property/">Property</a></span>
        <ul>
            <li><a href="/property/news/">News</a></li>
            <li><a href="/property/houseofweek/">House of the Week</a></li>
            <li><a href="/property/coverstory/">Cover Story</a></li>
            <li><a href="/property/commercial/">Commercial</a></li>
            <li><a href="/property/starterhomes/">Starter Homes</a></li>
            <li><a href="/property/tradingup/">Trading Up</a></li>
            <li><a href="/property/features/">Features</a></li>
            <li><a href="http://property.examiner.ie">Property Search</a></li>
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/lifestyle/">Lifestyle</a></span>
        <ul>
            <li><a href="/lifestyle/showbiz/">Showbiz</a></li>
            <li><a href="/lifestyle/fashionandbeauty/">Fashion &amp; Beauty</a></li>
            <li><a href="/lifestyle/foodanddrink/">Food &amp; Drink</a></li>
            <li><a href="/lifestyle/healthandlife/">Health &amp; Life</a></li>
            <li><a href="/lifestyle/homeandgardens/">Home &amp; Gardens</a></li>
            <li><a href="/lifestyle/travel/">Travel</a></li>
            <li><a href="/lifestyle/artsfilmtv/">Arts, Books, Film & TV</a></li>
            <li><a href="/lifestyle/features/">Features</a></li>
            <li><a href="/motors/">Motors</a></li>
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/info/help/">Help</a></span>
        <ul>
            <li><a href="/info/faq/">FAQ</a></li>
            <li><a href="/info/contactus/">Contact Us</a></li>
            <li><a href="/info/mediapack/">Media Pack</a></li>
            <li><a href="/info/privacypolicy/">Privacy Policy</a></li>
            <li><a href="/info/cookiepolicy/">Cookie Policy</a></li>
            <li><a href="/getmobile/">Mobile</a></li>
            <li><a href="/info/subscriptions/">Subscriptions</a></li>
        
        </ul>
    </div>
    <div class="foot-nav">
        <span><a href="/info/help/">Info</a></span>
        <ul>
            <li><a href="/info/terms/">Terms and Conditions</a></li>
            <li><a href="http://www.nni.ie">NNI</a></li>
            <li><a href="/epaper/">ePaper</a></li>
            <li><a href="/info/postaldeliveryenquiry/">Postal Delivery</a></li>
            <li><a href="/competitions/">Competitions</a></li>
            <li><a href="/info/syndication/">RSS</a></li>
        </ul>
    </div>


    <p>
        &copy; Irish Examiner Ltd, Linn Dubh, Assumption Road, Blackpool, Cork. Registered
        in Ireland: 523712.</p>
</div>
</footer>
    

    

    <!-- (advertising -usually to hold 1x1 pixel ad) -->
    <!-- n_ie_placeholder_1x1 --><div id='div-gpt-ad-1346688247801-12' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-12');googletag.pubads().refresh([n_ie_placeholder_1x1 ]);});</script></div><div id='imageDiv1x1'></div><!-- placeholder_2x2 --><div id='div-gpt-ad-1346688247801-3' style='width:2px; height:2px;'><script type='text/javascript'>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1346688247801-3');googletag.pubads().refresh([n_ie_placeholder_2x2 ]);});</script></div>
    
    
    
<script type='text/javascript'>
var _sf_async_config = _sf_async_config || {};
_sf_async_config.sections = 'Business_Bn,';
_sf_async_config.authors = 'BreakingNews';
_sf_async_config.zone = 'Breaking';

(function () {
function loadChartbeat() {
	window._sf_endpt = (new Date()).getTime();
	var e = document.createElement('script');
	e.setAttribute('language', 'javascript');
	e.setAttribute('type', 'text/javascript');
	e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_pub.js');
	document.body.appendChild(e);
	}
var oldonload = window.onload;
window.onload = (typeof window.onload != 'function') ?
	loadChartbeat : function() {
		oldonload();
		loadChartbeat();
	};
})();
</script>

   
    <script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
</body>
</html>
